S-10 Forum banner

1 - 20 of 35 Posts

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #1
Finally got it in. We had to heavily modify the bracket I bought. So much for engine specific brackets, bleh!

Anywho, it's on, and it's badass. I hooked the clutch wire to 12v and the compressor kicked on, sounded badass. I bumped it up to about 1500 rpms, my dad said it was blowing his hand away from the front on it :D

And that's not even full power!

Can't wait to get everything else done.. I'ma go take some pics, brb!
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #4 (Edited)
Excuse my dirty engine bay :D I haven't cleaned it in a LONG time.. Anyways, yeah, it's all in, finally. As I said, it lines up fine, works great, definately pumps out the air. I paid $85 for the original bracket.. bleh, spent $75 at machine shops making it work. I also had to have a new power steering line made up made of mostly plastic so I could bend it out of the way to clear the belt. The maker of the bracket never told me this... I also had to extend a vacuum line, and a few other things.

I ended up using a 103" belt. The original belt is 95.5 inches. I measured and got 105", so I went and got the 106.5", figured I could make it work, BUT forgot to pull the tensioner UP... bleh, so took that one back. Got a 100", it was too small. Went back and got 2 different sizes.. a 103 and a 104.5. The 104.5 was 29.99! The others were like 12.99.... big price different. Luckily the 103 worked and I get to take the 104.5 back and get my 30 freakin bucks back! :D

I'm gonna stick my intake filter and stuff on, and also teflon those compressor ports and put the elbows on. They're just stuck on there now. That's about all I can think of. If you have any questions, feel free to ask!
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #7
And no I'm not missing a nut in the 4th pic. That's the alternator bolt. The bracket is threaded, it's just the bolt is a bit too long. It holds just fine though :D
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #9
Yep, lowenuf90 from BlazinLow made the bracket. Funny how he won't reply to my IMs on AIM now. He's an idiot and do NOT buy from him.

And it's a 4.3 TBI.
 

·
Registered
Joined
·
143 Posts
DO NOT BUY FROM AIM PERIOD!! I've tried several times to get an order together from them and not once has it ever been right
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #13
No pics after I modfied it.

L-ROD: buy from AIM? What are you talking about?
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #14
OK, I did some more work today.

I ran my leader hose and I hooked it up to my tank and compressor. I ran the compressor for like a minute or so, and I touched the elbows on top of the compressor. They were HOT. I know they're supposed to get hot, but so hot you can barely touch it? I'll take some pics later on. I ruined my engine battery, it was junk anyways. I guess I'll go buy a new one sometime today or tomorrow.

I ran my leader hose down through a hole in the top of the frame that the e-brake line runs through. The line is routed around the hard brakelines coming off the master cylinder and up to my compressor. It's several inches away from the exhaust manifold.. probably 6 inches or so. It should be fine I think :D

Question, on my adjustable pressure switch, all the way tightened is the lowest setting, and as you losen it up, you're increasing pressure, correct? Or is it the opposite?
 

·
thats my boy with the box
Joined
·
549 Posts
the elbows are just thred on top ware the old fiting wer?? i have a york i'm going to put on and thay cut the lines to short to do eny thing with and i can't find fiting like them eny ware.. what kind of line are you running to your tank?? is it all steel braded??do you have some pic's of it all on??
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #18
rladieu3 said:
the elbows are just thred on top ware the old fiting wer?? i have a york i'm going to put on and thay cut the lines to short to do eny thing with and i can't find fiting like them eny ware.. what kind of line are you running to your tank?? is it all steel braded??do you have some pic's of it all on??
There's ports on top of my compressor. Male 3/4" NPT ports. I've got 3/4" NPT female elbows on top. I've got stainless steel braided line ran to my tank. You need it due to the heat engine driven compressors produce.

What fittings are you looking for and what line do you have? I can't understand what you're trying to say.
 

·
I <3 SPARKS
Joined
·
7,977 Posts
Discussion Starter #20
FoolishBlazer said:
I WANT ONE!!!!!!!!!!!

lol.. I dunno where it mounts on the 2.8. I dunno if it's a different placement or what. when I meet you, I wanna see your engine and see where it could mount. maybe by then I'll be able to weld and maybe we could make you a bracket :D
 
1 - 20 of 35 Posts
Top