S-10 Forum banner

1 - 11 of 11 Posts

·
"I Like Mine With No Shine"
Joined
·
53 Posts
Discussion Starter #1
Has anyone else had problems with their windshield wipers. I have had 3 s-10s and the wipers eventually quit working on all of them. I was just wondering if it was just me or if it was a big problem??
 

·
"I Like Mine With No Shine"
Joined
·
53 Posts
Discussion Starter #4
mine did the same thing. i would turn the switch off and they stayed on. THen they just stopped working in the middle of the windshield and then they would just start working again it was the damndest thing. I took the cover off the other night and cleaned the contacts off and put silicone around the cover to keep water out. They haven't messed up since. before, they would always work when it wasn't raining and would quit working when it was. then they just quit working all together.
 

·
Registered
Joined
·
12 Posts
Wiper question

Primed95, I have the same wiper problem now. What cover are you talking about?
thanks
 

·
Fever for the Flava
Joined
·
444 Posts
yep mine will do that to, i keep a hammer with me so when they dont work i smack the motor with the hammer and it starts workin.
 

·
Registered
Joined
·
21 Posts
I have a 98 2.2 (Hombre) and when I went to the Chevy dealer they told me that there was a recall on the 96 & 97 models but the 98 was not. They claim the board was upgraded. If I have a problem with my wipersw it would cost me $248 to replace the motor/board/relay because it is all built in. However, I have heard of MANY problems with 98 & 99 models with wipers quiting in the middle of a bad rain. I placed a complaint with variou agencies letting them know that it shoul be a recall part. Untill then...I will also find a hammer.
 

·
I rape little boys
Joined
·
1,329 Posts
yea...GM Calls it a wiper motor module....it is the module that regulates the time interblas and all for you Intermintant Wipers...they call it a cover...b/c the module is buillt into the wiper motor cover....and you replace toe cover and the modile and the same time....GM has come out with an updated module to corrrect the problem...most 96-97 Blazers, S-10, Jimmys, and S-15 had this problem.....and..don't do it..if you have never done this b4....you wipers will owrked really f*cked up..if you put the cover in the wrong position
Later
BAMT
oh and it is not a recall...just a technical service bulletin
and even the "updated" ones F*ck up too
 

·
The Heezy To The Skeezy
Joined
·
349 Posts
badassminitrk said:
yea...GM Calls it a wiper motor module....it is the module that regulates the time interblas and all for you Intermintant Wipers...they call it a cover...b/c the module is buillt into the wiper motor cover....and you replace toe cover and the modile and the same time....GM has come out with an updated module to corrrect the problem...most 96-97 Blazers, S-10, Jimmys, and S-15 had this problem.....and..don't do it..if you have never done this b4....you wipers will owrked really f*cked up..if you put the cover in the wrong position
Later
BAMT
oh and it is not a recall...just a technical service bulletin
and even the "updated" ones F*ck up too
This started happening in my 98 ZQ8, so should I pay GM to fix it or can I do this myself. If I do it myself what do I ask for and how much is the part by itself. I was quoted 200-300 form the GM dealer.
 
1 - 11 of 11 Posts
Top