S-10 Forum banner

1 - 4 of 4 Posts

·
I want you to drag or die
Joined
·
593 Posts
Discussion Starter #1
I've got a white face gauge insert with adjustable indiglo lights laying around at home. I bought them awhile ago, and started to install them, but the needles rubbed on it. I got them on ebay, and they can with horrible insructions. It said you didn't have to remove the needles, but you did. any way if someone could help me out and tell me how to properly install them that'd be great. I'm guessing you have to take the pins out of the speedo, but i didn't want to break them so i didn't.
 

·
Registered
Joined
·
1,114 Posts
What you have to do is warm up your truck and write down a diagram of where the needles are at when your truck is warm. Mostly what you have to worry about is TEMP and FUEL. After that, take off the gauge cluster and remove the needles. You can remove them with a screw driver or pliers, just pull them off very carefully. After that, lay the new gauges on and when you put back the needles, match them up to your diagram so you can get some what accurate readings. And that is it.

PM with Questions
 

·
I want you to drag or die
Joined
·
593 Posts
Discussion Starter #3
Yeah That is what i did the first time, the problem was the needles where rubbing on the white face insert. the speedo would like jump about 5 mph at a time, and a couple of the other gauges needles wouldn't settle back down when it was shut off. basically the white face was not in secure enough. how do i keep the needles from rubbing?
 

·
Gargling with doody juice
Joined
·
1,035 Posts
if they're sticking, you pushed them down a bit too far. i had to readjust them a few times, if you don't push them down far enough they'll fall back to the zero spot. i had the tach needle set wrong a few times, finally i just went 50 (since 5th gear @ 50 mph is 2000 rpms) and put it on while driving. worked fine.
 
1 - 4 of 4 Posts
Top