S-10 Forum banner

1 - 9 of 9 Posts

·
killin em softly
Joined
·
377 Posts
Discussion Starter #1
I had a post on here a lil while about a whining or a high pitch noise when I take off when my truck is cold. Anyways it happens mostly in first gear and usually goes away when you get out of first or are a little into second gear. My uncle is a mechanic at a Chevrolet dealer here in town and he informed me that it was the carrier bearing in between our drive shafts. He spent like 2 days trying to find exactly what was causing it on a customers Xtreme and finally found it to be the carrier bearing. I am having mine replaced on Tuesday. So if you are having the same problem, you might want to get it checked out.
 

·
Got Beer?
Joined
·
1,599 Posts
Is that the light squealing noise that happens when the truck is first started in the morning after being outside during a cold night? I get that all the time. If it is that, what type of problem can occur later on?
 

·
killin em softly
Joined
·
377 Posts
Discussion Starter #3
It sounds like that it is it. Im not real sure what type of problems it could present besides just eventually going out, cept for the annoying noise it makes. It might possibly be able to tear up the drive shaftat soem point but again Im not a mechanic so I dont really know.
 

·
Registered
Joined
·
100 Posts
Yeah my truck makes the same sound but from 16 to 21 mph then goes away . But it sounds like it is coming from the engine bay. My truck has 12k on it though.
 

·
killin em softly
Joined
·
377 Posts
Discussion Starter #5
my truck has 20k miles on it and it does it, the one that my uncle worked on had 15k miles. So I dont think that yours would be ruled out with only 16k or whatever it was
 

·
Registered
Joined
·
1,386 Posts
alot of the sounds you here from a cold take off is the clutch fan, I also let mine idle down before taking off. I have also heard its not good to start up-put it in gear and go, its best to let it warm up a bit...just my .02
 

·
killin em softly
Joined
·
377 Posts
Discussion Starter #7
I got the new carrier bearing put in and there is no more whining sound anymore. I also put a set of Monroe Sensa Tracs put on the rear because my passenger side Bilstein was f*cked up cause it would not compressall the way which made my truck ride like crap. Anyways I like the sensa tracs so far but we'll see how they work out.
 

·
Registered
Joined
·
25 Posts
ya mine does the same thing. If you just let it warm up it wont do it. I work at a dealership and I replaced everything there is to replace and still the whining sound. Ive been in other s10 and it does the same thing.
 

·
Hell Bound
Joined
·
262 Posts
I find that for warming the truck up in the morning u gotta give it at least a little gas tho, or else with mine at least i can be sittin there for like 15 minutes and not see the needle move a hair
 
1 - 9 of 9 Posts
Top