S-10 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
After my trucks warms up, and the idle speed drops, It idles rough, i've heard alot of people talk about possible vacum leaks...where are common places to look? Up around the TBI? I got big gaps between the EGR Ring around the TBI and the airfilter, could this be a possible cause? Also Im in the middle of replacing my intake manifold, I removed the distributor, but since Im reaplacing the manifold, I didn't mark it where it was in its rotation, If I guess and put it back and it's in the wrong spot, WIll the engine blow up? Thanks a bunch

-Steve
 

·
Grrr
Joined
·
1,575 Posts
well dude...if u take off the manifold...thats where all the vacuum lines are. just check all the little hoses for cracks or leaks. did you do the throttle body airfoil mod? is it leaking there? Check your throttle body anyway for any way air could be getting by it.
As for the distributor. I hope ur a good mechanic cuz u really screwed yourself with what u did. You now must get piston number 1 to top dead center...then there is a method to line up the rotor where it needs to be...nnot sure where that is though. Then u need a timing light to set your timing by twisting the distrubutor.
This summs it all up for you:rolleyes: :cry: :bash:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Great

Yea i figured as much :( Anyway, I'd haveto re sync the distributor anyway since the manifold is coming off, there is no way to mark it's last position. I'll figure this out but thanks for the heads up and advice :)

Keepin it real with no truck,

-Steve
 
1 - 3 of 3 Posts
Top