S-10 Forum banner
1 - 11 of 11 Posts

·
"i got that slap"
Joined
·
3,526 Posts
Discussion Starter · #1 ·
this happened a few days ago and i never got around to posting pics....i'm lucky i was doing 20 when it came off









everythings straight now
 

·
Registered
Joined
·
3,157 Posts
dang dude just count yourself lucky that wasn't on the interstate or something! doesn't look like you sustained too much damage, how's the underside look?
 

·
Give me 3 yrs...
Joined
·
6,519 Posts
i take it u didnt replace the 2 studs that were broken when u took pics of the bagging lol, i love ur but u shoulda gotten those fixed.... lol still good tho
 

·
"i got that slap"
Joined
·
3,526 Posts
Discussion Starter · #7 ·
JollyRojer said:
i take it u didnt replace the 2 studs that were broken when u took pics of the bagging lol, i love ur but u shoulda gotten those fixed.... lol still good tho
:haha::haha::haha: nope...i had the studs for them...but they were broken off flush with the rotor and all rusted so they were NOT coming out..lesson learned: always have all your studs!
 

·
Registered
Joined
·
1,660 Posts
sorry to hear, but i sure woulda loved to see that lol
 

·
Low Hardbody
Joined
·
93 Posts
your lucky i was going down the road cruzin about 45 minding my own business next thing i know i see my tire flying and i went dragging for 40+ feet and i dont have bags it ****ed my brand new 4x4 fender boy was i pissed
some haters from school loosend my lug nuts i was lucky though i didnt lose control and go off the road or i really would have been ****ed
 

·
Registered
Joined
·
1,442 Posts
that sucks how did u get the wheel back jsut go fetch it?
 
1 - 11 of 11 Posts
Top