S-10 Forum banner
1 - 8 of 8 Posts

·
Problemchild
Joined
·
138 Posts
Discussion Starter · #1 ·
i was puttering around on my truck and just realized that i have over 122k miles on a 96 4.3 auto and i havent really had somethin MAJOR go out.."KNOCK ON WOOD!" the only thing i remember really fixing is replacing the heatercore and once again it went out..radiator stupid plastic peice...intake manifold gasket other than nothing.. what part should i be looking to get serviced or have on mind for my pocket when it goes out..any advice will be greatly appreciated any part of the truck inside and out..
 

·
resident bmx prick
Joined
·
444 Posts
be careful... even when stuff breaks, youll still be faster than the 2.2 :-D
 

·
Got Fuel Rails?
Joined
·
4,539 Posts
Fuel pump, alternator, and waterpump are probably getting there as far as their service life. I wouldn't replace them until they give up though.
 

·
Registered
Joined
·
26 Posts
The only MAJOR problem I have had on my 96 Blazer was the intake manifold gasket going out at about 155k miles (which caused irrepairble damage) I am at about 160k miles now and am on my 3rd transmission...

Other than that, I have had to replace every o2 sensor, my alternator has gone bad twice and fuel pump has been replaced once, starter motor kicked the bucket around 5k miles ago. And the engine mounts rusted through.
 

·
Registered
Joined
·
1,370 Posts
Keep up with the maintenance on the auto trans. but other than that, if you've kept the oil and filter changed it will probably run forever. I rebuilt my Engine at 159,000 because it was leaking oil from the rear main. But the bearings and crank were fine. The cylinders were in good condition, as were the pistons. It would run for another 100,000 miles... But i wanted to go faster than the stock stuff could take me.
 

·
Problemchild
Joined
·
138 Posts
Discussion Starter · #8 ·
i also have replaced my alternator many times along with the water pump once and im running with an auto but ive noticed that the tranny has been acting up. it kinda will clunk when i leave off a light like for example it almost doesnt wanna engage back into gear and if i press the gas a bit it will enventually ram into gear. and i also have noticed an oil leak not quite sure where.i know it drips onto the exhaust pipe cuz i can see the oil and smell it burning. i have been running 10w45 oil with lucas oil treatment.
 
1 - 8 of 8 Posts
Top