S-10 Forum banner
21 - 36 of 36 Posts

·
Anybody got 20's?
Joined
·
5,731 Posts

·
Anybody got 20's?
Joined
·
5,731 Posts

i see four myself
Ok now I see. Its hard to tell. I don't know how the connections hookup on a powersteering pump from a 2.2 because that looks alot different then the one on my 4.3. My high pressure line comes out from the lower back of the pump. Everything is okay now. The elbow he posted is wrong because it is a 6an 45* flare. The one that is needed is a 6an 37* flare.
 

·
Anybody got 20's?
Joined
·
5,731 Posts
How do you know those fittings (saginaw) are 37* ??

if it was wrong.. what would happen??? I don't have any leaks
Because I had them in my hands and they don't work at all. The flare nut is way too big. Also I talked to tech support for an hour and I found out they were the wrong ones. You must not have the ones that you posted a link to. You have the FBM1122 elbows.
 

·
Anybody got 20's?
Joined
·
5,731 Posts
i must posted the wrong one then... cuz mine fit just fine..nothing seemed to big or anything... i guess i should look into it.. just incase
I mean yours should be alright. My parts in no way would connect at all. The flare nut would slip right over the threads so it was clearly too big. I did a search on here and found this. http://www.s10forum.com/forum/f125/blazer-on-22-s-334161/ Scroll down to post # 49 and it shows the right elbows.
 

·
body droppin'
Joined
·
1,546 Posts
I wish I would have known that before I made that post haha. I spent over $200 on the lines and fittings from hydratechbraking.com
 

·
DOORED AND CHOPPED
Joined
·
226 Posts
thanks for cle4arin this up im about to embark on this i got the booster whats keeping anyone from using the factory astro lines and adding a tee? i also have a 1st gen if it makes a difference. thanks for any help.
 

·
boosted 2.2L
Joined
·
2,323 Posts
sorry to drag this up from the dead.
wish I would of read the whole thread before I ordered parts.
the 90* fittings are definately wrong

the fbm 1122 is what you need
 

·
Registered
Joined
·
604 Posts
do i actually have to use the braided line here too??? line from somewhere else wouldnt worked??? autozone or o'reilieys wont work? just curious as i am doing the hydroboost setup this month
 

·
Afterhours Admin
Joined
·
27,121 Posts
Ive been doing hydroboosts for years and never used the braided line (altho it does look better.) If you take the s10 pressure line off the box (from the pump), it will screw right into the hydroboost, youll need to bend the steel portion a bit. The astro pressure line from the booster to the box then bolts right in.

I also fixed the first post to correct the fitting.
 

·
Registered
Joined
·
366 Posts
This thread has been helpful to me, so I figured I'd share what I used.

the stock S10 line didn't look long enough to reach for my application, and I didn't want to bend it up and find out the hard way, so I ended up with the two below.

avalanche hose from pump to hydroboost, astro hose from hydroboost to gearbox. Edelmann 39106 return fitting (for gearbox) and crown 5370019R hose for the return line (all from summit). McMaster 91355K48 T-fitting.



 
21 - 36 of 36 Posts
Top