S-10 Forum banner
2481 - 2500 of 2519 Posts

·
Registered
Joined
·
276 Posts
So I got hit last week, what do y'all think I should do, take the $1,400 check that their insurance company estimated at one of their shops or just have them fix it?
But I also noticed they are trying to give me a black bumper when I added the Chrome bumper, so I guess they looked up the VIN and seen it was just a base so that's what they will give me I guess?
IMG_20210629_151009.jpg

Screenshot_20210628-150921.png
IMG_20210628_180050.jpg
IMG_20210628_180103.jpg
 

·
Registered
Joined
·
1,819 Posts
That is definitely not a hard repair.
 

·
Registered
Joined
·
12 Posts
So I got hit last week, what do y'all think I should do, take the $1,400 check that their insurance company estimated at one of their shops or just have them fix it?
But I also noticed they are trying to give me a black bumper when I added the Chrome bumper, so I guess they looked up the VIN and seen it was just a base so that's what they will give me I guess?
View attachment 351243
View attachment 351240 View attachment 351241 View attachment 351242
does not look bad. cool if you have some body work experience and can remove the dents. if not you either get a cheaper shop or just lear to live with and pocket the 1.4k
 

·
Registered
Joined
·
625 Posts
The high pressure switch on the back of my AC compressor on my 03 Sonoma decided to blow its head off today. Taking all my R134 with it. It is definitely the 13th. Ugh.
 

·
B4U Task Force Admin
Joined
·
29,526 Posts
The high pressure switch on the back of my AC compressor on my 03 Sonoma decided to blow its head off today. Taking all my R134 with it. It is definitely the 13th. Ugh.
At least it's not Friday...
 

·
Registered
Joined
·
12 Posts
The high pressure switch on the back of my AC compressor on my 03 Sonoma decided to blow its head off today. Taking all my R134 with it. It is definitely the 13th. Ugh.
im debating to see if i put some money on the AC. i can get AC compressor. condenser, drier and expansion valve for like 250 is the labor. that will make it not worth it.
 

·
B4U Task Force Admin
Joined
·
29,526 Posts
You can install them in a short amount of time. Take it in and get it charged for $100.
 

·
Registered
Joined
·
625 Posts
im debating to see if i put some money on the AC. i can get AC compressor. condenser, drier and expansion valve for like 250 is the labor. that will make it not worth it.
Here's a link to the kit I used from AutoZone. Works well had no real issues with it. But I recommend to use the ACDelco orifice not the one that comes in the kit. The AC Delco works better. And it's only like four bucks on Amazon. This kit is for the 4.3L not 2.2L
https://www.autozone.com/cooling-he...ntech-kit-a-c-compressor-p96-23950/479432_0_0
 

·
Registered
Joined
·
625 Posts
Today just keeps getting better started to recharge my AC pump starts knocking low pressure jumps from 30 up to 90 PSI. So now I need to pull everything out and flush everything and replace pump dryer and orifice. Only positive thing is the ac kit I purchase has a lifetime warranty from AutoZone .
 

·
Registered
Joined
·
12 Posts
Here's a link to the kit I used from AutoZone. Works well had no real issues with it. But I recommend to use the ACDelco orifice not the one that comes in the kit. The AC Delco works better. And it's only like four bucks on Amazon. This kit is for the 4.3L not 2.2L
https://www.autozone.com/cooling-he...ntech-kit-a-c-compressor-p96-23950/479432_0_0
sorry to hear about the AC problems.

yea i get some discounts at Advance and i can ge the whole ac compressor kit+. condenser for $250. just need to see with a shop about how much is the Install+ recharge
 

·
Registered
Joined
·
625 Posts
sorry to hear about the AC problems.

yea i get some discounts at Advance and i can ge the whole ac compressor kit+. condenser for $250. just need to see with a shop about how much is the Install+ recharge
Thank you. I did put this system in just over 5 years ago. I replace the condenser and orifice last year because of cooling issues. The stock condenser was partially plugged up but I didn't see any metal in the system so I didn't change the pump but I should have. This time I'm going to try the ACDelco auto adjusting orifice they are supposed to work better especially at idle.
 

·
Registered
Joined
·
625 Posts
Today on my 03 GMC Sonoma I will be flushing my AC condenser and evaporator and hoses with 99% isopropyl alcohol to get all the dark green leprechaun blood out. that's what it looks to me.🤣
 

·
B4U Task Force Admin
Joined
·
29,526 Posts
Today on my 03 GMC Sonoma I will be flushing my AC condenser and evaporator and hoses with 99% isopropyl alcohol to get all the dark green leprechaun blood out. that's what it looks to me.🤣
Vulcan blood...
 

·
Registered
Joined
·
1,819 Posts
Dropped a set of C5 wheels off at the powder coat shop.
351500


I had planned to do this months ago but the cost was out of the budget.
 

·
B4U Task Force Admin
Joined
·
29,526 Posts
Fired up the truck for the first time in a month. Battery was almost dead. Hooked up the little jump box and it fired right up. Taking it down to Harleys Saturday for a little transmission R&R. Got a vibration that we think we have the issue narrowed down to....🤞🤞🤞🤞🤞
 
  • Like
Reactions: Gen210

·
Registered
Joined
·
106 Posts
Well, I might be getting rid of the turbo'd s10. Had it running quite well despite the smoke pouring from every breather on the engine, until I had to give someone a prolonged jump start. Killed my battery and once I got it jumped I couldn't get it much above 1k rpm and it eventualy died. After charging the battery it would only crank via directly shorting the solenoid and ended up shredding the plastic gear inside of the starter trying to get it to run. Pulled a yunkyard starter and it still wont crank with the key (but will via manually triggering the solenoid) but won't start. It has no spark. I did notice the rear pass cylinder had it's wire melted from oil/no manifold shield so I'm thinking that it might have lost it's connection on that cylinder and fried the ICM. With that said, I had the pcm (0411 swap) not secured and it shifted arounnd quite a bit and seemed to have burned up at least one wire. The PCM itself is still readable/writeable so I don't think that is the problem

Considering I paid $700 for it with the only requirement being "make it through winter with 4wd", I'm thinking bout calling it quits on the old girl. Sure it was fun pushing 400+hp on a bone stock engine but I'm sick and tired of working on it. Figure that time/energy would be better spent on my '00 astro lt awd instead. I'm trying to convince myself that doing a strealth mid mounted turbo on the astro isn't a good idea, especially since it's in mint condition. The other part of me is saying "just do it, it'll be a perfect sleeper". I guess we shall see what I end up doing once I finish doing the astro's upper and lower ball joints, idler arms, tierods, rotors and brakes.
 

·
Registered
Joined
·
625 Posts
It feels like I'm still having fallout from the 13th. I lost my second accessory wire off the ignition switch the brown wire it's completely dead. And no one has it in stock I have to wait until tomorrow to get one. :(
 
2481 - 2500 of 2519 Posts
Top