S-10 Forum banner
1 - 4 of 4 Posts

·
wrench turner
Joined
·
19 Posts
Discussion Starter · #1 ·
03 s10 zr2 4.3 auto 4x4. the dash light never lights up not even when the "test" does its thing when u turn the key. its a led so its most likly not the light (led) its self. With out the thing turning on i cant do the key relearn for the vats. any help?
 

·
Been there Done it
Joined
·
12,460 Posts
AFAIK the security light is not an LED. It's a mini bulb permanently attached to the base. They are #74 or PC74 for replacement. Almost all replacement bulbs are now LED, tho. But I doubt that's the problem.
In the underhood fuse block in the lower right corner is the TBC fuse. It's likely blown. It's the power for the Body Control Module. If it's blown the light won't come on and you can't do a security relearn. The only other possibilities that comes to mind are the wire from the fuse block to the BCM is broken. The connector C1, the one with 5 wires, at the BCM is loose or corroded or one of the 2 the black ground wires in that connector isn't grounded. Either pin A1 or B1 in connector C1.
Click on the pic and then click the + button to see this larger. Sometimes you have to refresh the page first.
Took some research to find this, it wasn't in my 03 wiring diagrams.
349781
 
  • Like
Reactions: davidgirod

·
wrench turner
Joined
·
19 Posts
Discussion Starter · #3 ·
i checked the cluster and it is a led and the diagram you posted is showing its a diode...a led. but i do thank you as i havent ever seen this wiring so its info to help figure it out.
 
1 - 4 of 4 Posts
Top