S-10 Forum banner

1 - 6 of 6 Posts

·
Again! It's a 5-cylinder!
Joined
·
82 Posts
Discussion Starter #1
Hi folks!

Im getting a water "sloshing" noise during acceleration, it even happens while the 1996 Jimmy is in park as I rev the engine? The noise seems to be coming somewhere in the dash/glovebox area while driving, in park it sounds like its under the center console??

Any ideas?

Thanks
 

·
PPG Sprayin Minitrucker
Joined
·
1,038 Posts
Its probably just your antifreeze moving through your heater core.
You might wanna check it and make sure its not low. On my fullsize when it gets low I can hear the same thing.
 

·
Insane Network Engineer
Joined
·
5,965 Posts
It's the dexcool..(that stuff is crap) More than likely it is sludging up..(hence the lawsuits on it).... Have your cooling system ACID flushed at the very least (even if you want to stay with Dexcool) Otherwise you're likely to have your rad or heatercore blown out..
 

·
Kramerica Industries
Joined
·
342 Posts
I've heard some people complaining of this when their A/C drain hole plugs up.
Condensation can't escape, thus the water sound.

But with Dex-cool an acid flush and refill would be a good idea, even if it doesn't fix your problem (which it may).
 

·
Registered
Joined
·
498 Posts
Check coolant level first, and actually take off the radiator cap and check it there. If the coolant is low make a point to start checking it now and then. If you are losing coolant you need to find out where it's going. Not all that rare for the stuff to be going through the intake gaskets into the crankcase, not good.
 

·
Registered
Joined
·
18 Posts
If the coolant isn't low, have you had any heater hoses replaced?

A lot of modern vehicles have restricters in one of the heater hoses to reduce internal erosion of the heater core by the rapidly flowing coolant. A side benefit of the restricter is that the slower moving coolant doesn't make as much noise going through the core. Aftermarket hoses may not include the restricter.

I don't know if 2nd gen Blazers/Jimmys have one or not (my 1st gen '94 doesn't).
 
1 - 6 of 6 Posts
Top