S-10 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
i have a 1998 5 speed S-10 that is vibrating and making a humming noise. i jacked up the rear end and put her into 1st gear. i noticed the driveshaft not spinning in a perfect circle, but more of a wobbling circle.
this problem just started monday morning driving to work. the faster i drive the more vobrating/noise i get. i have posted in other forums and have gotten different answers. some have replied that it is the carrier bearings, u-joints, and unbalanced shaft. being a 2.2L, i do not drive my truck hard. does my truck have a carrier bearing? i looked at the driveshaft and seen a weight on it. how many should be on there? i moved the shaft up/down and front to back and there is no play. the tires were replaced 4 months ago and still have the balance weights on them, so i am ruling unbalanced tires out. my only guess would be the carrier bearings if i do have it. what would you think?

--scott
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
unbalanced shaft, or u-joints....

Caleb
 

·
Unlawful Creations C.C.
Joined
·
263 Posts
i agree with summerwolf
 

·
Afterhours Admin
Joined
·
27,121 Posts
Is your truck an ext cab or longbed model? Those are the only two that have the carrier bearing. If you have a std cab short bed then you dont have it. If your driveshaft isnt spinning in a circle and its wobbling, theres more to it than an unbalanced shaft. Sounds like something is damaged, maybe the shaft is bent. Bring it to a qualified shop.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
i do not have an extended cab.

how much wobble should i get if any?

it has gotten worse and hear another noise like bb's in a metal can. not sure if this is a different problem for just the same problem getting worse.

--scott
 
1 - 6 of 6 Posts
Top