S-10 Forum banner

1 - 17 of 17 Posts

·
ELTC
Joined
·
8,391 Posts
Discussion Starter #1
installing my 380 backup today ( AND YES GUYS I BOUGHT A P/S:haha:) and was wondering about the leader hose.. I have seen alot of threads with guys says Viair's leader hose's suck and then some guys saying they have never had an issue with them. I guess I am just wanting to see what you guys can give me on positive / negative about it.
 

·
Registered
Joined
·
889 Posts
well id ahve to say they dont suck but there not good, i installed a 450 and started seeing a leak, so i felt around and found it was leaking at the compressor head where the leader hose screwed in. but i though these leader hoses had a check valve in them, guess it went bad. just check every thing after you instal it.
 

·
Registered
Joined
·
26 Posts
i have the viair 380s. both leader hoses broke on me when i was loosening them to take them off. i just bought some steel braided hoses from home depot and called it a day
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter #6
well everything with mine went all together today without a problem. luckily.
im installed a KP single needle gauge just for my tank pressure but i dont have the fitting for the back of the gauge..why wouldnt it come with the gauge and where can i pick one one up? home depot or autozone maybe?
 

·
Extended cab or no cab.
Joined
·
19,980 Posts
never had a problem with mine in the one year ive owned them. just put the compressors on and run them. a leader hose is no reason to be afraid when you have your edc. I know that you had a edc from all the threads you posted.:p
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter #8
lol yea what a f*ckin nightmare all that was..everything is good now tho
edc with 380 backup..works for me

now how about those fittings for the back of KP gauge where to find em..
i been busy in the driveway all day with the truck so i never got out to go looking for them
 

·
ELTC
Joined
·
8,391 Posts
Discussion Starter #11
you the man cameron thanks again
 

·
goin over the falls
Joined
·
1,289 Posts
last year i had two of the viair hoses go within 2 weeks of each other. The first one you can see a burn spot where it got hot and then i took the hose off of my other compressor i never installed and used that. Then that one split at the check valve. I now have two real good steel braided hoses that were made at a hydrolic shop that are rated for 150 degree temp and 400psi.
 

·
N Da Werx
Joined
·
741 Posts
i've never had a problem with the viair 380 leader hose on my truck...
 

·
Registered
Joined
·
448 Posts
both my 380s leader hoses went within a week of install , lance sent me new ones that have been going strong for a few months. maybe they had some bad 1/4" leader hoses ?
 
1 - 17 of 17 Posts
Top