S-10 Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #1 ·
I recently found several rubber vacuum lines which have disintegrated on the motor of my 2000 Extreme. One of the vacuum 5/32" lines is on the driver's side of the engine compartment and appears to be part of the main harness near the firewall. The 7/32" line goes to the top of the throttle body. See picture below.
Road surface Grey Asphalt Font Wood
Vertebrate Automotive tire Motor vehicle Handwriting Tread
White Automotive tire Hood Motor vehicle Electrical wiring


What I am trying to determine is where and to what does the vacuum line hook up to? Does anyone have a vacuum line diagram for the 2.2L in my 2000 Extreme?
 

Attachments

·
B4U Task Force Admin
Joined
·
30,393 Posts
Never mind...just noticed it was a 2.2.
 

·
time to get cereal
Joined
·
5,669 Posts
literally the most common topic ever posted. Search bar is at the top.
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #4 ·
Thanks for reminder...after reading several threads, found the hidden vacuum reservoir! Didn't realize one was even there! Once I replaced the rotten vacuum hoses and established the designed vacuum routing, all HVAC functions are now operating properly (y)(y)

Now awaiting next gas fill-up to see if my gas mileage improves due to correcting that vacuum leak. My 2.2L, with the exception of a K&N air filter setup, is basically stock and the MPG is hardly hits 20 miles.
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #5 ·
One last item: Is there something missing as indicated in the attached pictures? Also, there is a capped plug?
Automotive tire Hood Motor vehicle Steering part Steering wheel
Hand Automotive tire Motor vehicle Finger Electrical wiring

From your experience, what could have been removed? Thank you in advance!
 

·
time to get cereal
Joined
·
5,669 Posts
That's where the cruise control would mount if you had it (and is probably what that plug is for), but those holes look more like a alarm system siren used to be there.

Car Vehicle Hood Motor vehicle Automotive design
 

·
Been there Done it
Joined
·
12,489 Posts
I agree, that's not the bolt pattern for a Cruise control module. I believe the wiring always included the connector so GM didn't have to make different harnesses for each option. Since it has a cap probably never was installed. If it had been removed where did they get the cap? Not like you can go to a dealer and order a cruise delete wiring connector cap.
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #8 ·
OK...thanks for the information and suggestions guys! If that plug is indeed for cruise control, hmmmm...possible project in future. Thanks again!
 

·
time to get cereal
Joined
·
5,669 Posts
I believe the cruise harness is part of the tilt steering option. I don't think I've ever seen factory cruise on a fixed column, always aftermarket. I would guess you have a tilt column then? Adding it might be hit or miss depending on the programming in the computer.
 

·
Registered
‘95 LS 2.2L Manual RWD
Joined
·
365 Posts
I believe the cruise harness is part of the tilt steering option. I don't think I've ever seen factory cruise on a fixed column, always aftermarket.
Are you referring to later models? Your '95 has cruise and no tilt.
 

·
time to get cereal
Joined
·
5,669 Posts
Are you referring to later models? Your '95 has cruise and no tilt.
Yea, 98+. My '01 didn't have any cruise wiring, but it did have a bunch of stuff in the column for an automatic transmission.
 
  • Like
Reactions: BigPapa

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #13 ·
Mystery of component on firewall solved: It was an alarm module that the second owner removed.

Gas mileage is still very poor...18 mpg! I'll have to keep looking for clues...
 

·
It's mostly BS
Joined
·
2,936 Posts
Short trips around town will give you that kind of mileage. If you're in town with some hw, you should be able to do mid 20s driving like Grandpa. In any case, dirty injectors will hose the mileage. I cleaned mine a few years back and it made a big difference since they were quite imbalanced. See this:

 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #15 ·
Rimara, I guess you looked at my profile and found that I am indeed a grandpa ;) Thanks for the suggestion! My 2000 Xtreme only has 49k miles but it probably is worth looking at the injectors. How did you clean your injectors? By removing each and cleaning them or just running injector cleaner fluids thru the system?
 

·
time to get cereal
Joined
·
5,669 Posts
If it's a VIN 5 (Flex) you can just run a tank of E85 through it, that should clean them out.
 

·
Registered
Joined
·
1,046 Posts
Discussion Starter · #17 ·
Not a flex. Thanks...Guess, I'll give a can of Sea Foam Marine PRO a shot next time I fill'er up.
 
1 - 17 of 17 Posts
Top