S-10 Forum banner

1 - 9 of 9 Posts

·
Give me 3 yrs...
Joined
·
6,526 Posts
Discussion Starter #1
its a 98 2.2l reg cab spd just hit 100k... im pretty sure its just the classic clogged/rattling cat but lemme know if u guys think its anything else...


SYMPTOMS (sp)

loud rattle at low rps
rich unburnt fuel smell sometimes at idle/low rps
startup it wants to die after i clutch out in 1st gear, i hafta clutch back in and rev it a tad to keep it from dieing.


not truck totalling problem but if its the cat i wanna just cut to sob off and straight pipe it, also wats the sensor in front of the cat? how do u check it? i looked briefly at it and it looks to be bung welded in.... wat other things could be causing the problem, ive noticed a slight decrease in mpg especially city driving. lemme know guys wat all i should check/replace on this thing
 

·
Give me 3 yrs...
Joined
·
6,526 Posts
Discussion Starter #3
yea.. sounds like the packing inside has broken loose and is rattling . The sensor in front of the cat is an O2 sensor which you will want to keep.

that why it smells like its running rich? and almost dieing?
 

·
355 member
Joined
·
13,485 Posts
could it be the inch and a half of water you picked up coming through PA this weekend :haha:
 

·
Registered
Joined
·
213 Posts
All of your symptoms could be caused by a clogged/bad cat, your probably not going to be able to tell much else until you replace it. Hit the cat with a rubber mallet if it sounds like the insides are rattleing around, its just like biggeris better said, the inside broke loose
 

·
355 member
Joined
·
13,485 Posts
could it be the inch and a half of water you picked up coming through PA this weekend :haha:

oh man, wrong person. just ignore me
 

·
Give me 3 yrs...
Joined
·
6,526 Posts
Discussion Starter #8
ya ive called gm and my cat (over 80k) and my wiper motors (incorrect vin for replacement) were denied, soo ok ill change the cat out n we will see how it goes
 
1 - 9 of 9 Posts
Top