S-10 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 · (Edited)
Ok, so this is the long story short. I had a leaking fuel injector on my 95 sonoma 2.2 5 speed. So I bought a new one pulled the throttle body and fuel rail bracket, removed the leaking injector installed the new one made sure it was seated properly. Put everything back and go to crank it and just clicks one time and goes dead, won't even turn over. So i think hell guess the battery kicked it, after all it was 4 years old took it to Auto Zone and O'Reily to have it check both said it was fine. So next on my punch list check the starter, dropped it but left the solenoid wired and turned the ignition and the starter turned over hmmmm.. so i bolt it back up and same thing won't turn over. So now i am thinking damn problem is more severe, so i start taking it back apart retracing every step from the injector install mind you previous to the install it started just fine. and as i pull the air intake there is literally fuel spilling out of the throttle body and i mean pouring. At this point I am soaking up the gas with some rags and i then pull the throttle body and the intake ports are full of fuel. I pulled the plugs they're dry. So it seems i am not getting fuel into cylinders at all. Almost like a vapor lock? So my question is what could this be?? what did i do wrong? how can i fix it? Where do i start? Help me!
I have never seen fuel leak out of these areas unless the fuel pressure regulator is leaking and the fuel is being sucked into the intake through the vacuum hose going to the regulator. The fuel injectors obviously are in the lower intake manifold and one would think it is impossible for fuel to leak into your upper intake from them. Right?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
Ok, So i was able to turn the engine over manually no problem. Tried to push start it and it was a no go. I guess next thing to do is pull the starter and have it bench tested. Any other suggestions?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Ok. Update I replaced the starter today and went to turn the key and it turned like a 1/4 turn then went back to just a click. Charged the battery and tried again same deal just a click won't engage the flywheel. So I am completely stumped with this, Do I spend money just replace the battery or what else can i check??
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Ok think i found the issue, for the hell of it pulled all the plugs as i was pulling the 3rd cylinder gas began to pour out of the block. So then i began to turn the motor by hand with about 2 gallons of gas pouring out onto the concrete until the gas quit coming out. Apparently it was hydro locked with gas flooded in the cylinder that i replace the injector i turned the key with the plugs out and gas shot out of the plug hole on cylinder on the block the motor now turns over. I am going to let it all dry up replace the plugs and try to fire it up Sunday. Wish me luck. Any other recommendations?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Ok here we go well the truck turns over until the cylinders fill up with gasoline again. I don't know what the hell is happening but gas is just pouring out of the block once i pull the plug and turn the engine manually it continues to turn over with key turn until once again it floods. I have unhooked the injector that i recently installed and it still floods out where the hell is all this fuel coming from and what do i need to do??? Damn this is frustrating.
 
1 - 5 of 5 Posts
Top