S-10 Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
i have a 99 sonoma. the security light has been on for a little bit. i did not think anything about it, until now and it will not start. i was told that it was the ignition, but i do not know for sure. have to get it fixed asap. really need some help.
 

·
Registered
Joined
·
63 Posts
well its prolly the ing switch. but i had a problem like you wear my securtiy would come on and some gauges would not work. i had the ing switch replaced by chevy 240.00 that was not the problem. new they said i need a new cluster they wanted over 400.00 so i just bought one off ebay
 

·
Oh shit....
Joined
·
11 Posts
are you using factory keys? Some key copies will not work because the truck reconizes it as something other than the original key, causing it to go "secure". this would cause a no-start situation.
 

·
Registered
Joined
·
4 Posts
dude if this dont fix it ill pay it off or buy it!!!!! unhook the battery for 30 secs. to clear all codes in the ecm, then with the key out of the switch hook the battery back up now get in the truck and put the key in and turn it to the run position....and walk away for about 15 mins. then go back and turn the key off pull it out and put it right back in and the ****er will start.!!!!!!!!!!!!! it sounds stupid as hell but my sunfire done the same damn thing! the passlock sometimes recieves interferance(gm forums explain) and when this happens the passlock system dont recognize the ignition switch(not the key as many people think!) and by doing the steps i gave you you can reset the passlock your self i have a good friend that works for general motors thats how i found about this! if it dont work the first time dont give up try it 2 or 3 times before you bitch at me lol! let me know what happens!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #11 ·
have not got to try it yet, went home to put my new wheels on my 97 silverado. going to try it tomorrow
 

·
Registered
Joined
·
421 Posts
go to autozone and buy one of those actron diagnostic things and erase the cose and then bring it back...
 
1 - 14 of 14 Posts
Top