S-10 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
Lastnight I was coming back from dropping off a bike.......was pulling my small bike trailer........was running the truck pretty hard (for the 4-banger round trip was around 200 miles) and about 10 miles from the house......the truck dies........all the electrical worked (gauges lit up like a christmas tree).......popped it into to neutral and coasted to the side of the road......hit the key and fired right back up.

The truck was not showing that it was overheated.....the only thing I did notice was that just before the truck shut off....when I stepped on it.....it seemed to shift from one gear to the next kinda of funny.....like it could not make up it mind what gear to be in (4 speed auto).........no check engine light or anything after getting home........I have a Helix power tower/homemade cold air with APC filter and the Gibson cat back exhaust on it........the intake (whick is heavy duty flexible 3" tubing did feel pretty warm.....was in the low 80's here on the North coast of Ohio).......the truck has just a little over 8,000 miles on it......2000 Extended cab 4 cyl 4 speed auto.


Anyone else experinced anything like that before???.......if it does it again I 'll take it back for the dealership to look at.........oh by the way......the dealership replaced the front rotors and fixed the timing chain/oil pan gasket leak.........at least that was done right.......under warranty.....

Any suggestions would be helpfull.....

Ridin the Glide (and the truck when it rains now)...........Cozmo
 

·
Paint Needing Mofo
Joined
·
639 Posts
Yep, mine did that once too, with about 3000miles on it. It's never happened again...(knock on wood)
 

·
Registered
Joined
·
1,082 Posts
i hit a bump the other night and mine shut off, everything lit up, then they went out. mine semmed like it went out of gear too. when i stepped on the gas nothing happened. i never shut it of just shifted it neutral. it reved up when i pressed the gas now. i put it back in drive and went on like nothin was wrong. i did something like this once before, but when the lights cut off it was like nothing ever happend. it just kept goin. both times it was the same bump on the highway. its not a big bump either. not big enough to make me bottom out.
 
1 - 3 of 3 Posts
Top