S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a '99 S-10 and have had some problems. I would like to know if this is typical of the S-10 or if mine is just a problem child. My last car (a toyota) went 123,500 miles with only 3 visits to the shop(I do most of my own routing maint). I love the appearance of the truck but the upkeep is killing my bank acct.

1) at 12,300 miles my starter went bad.

2) at 17,000 my tranny started to slip.

3) at 29,000 my tranny began leaking fluid. Not much, but enough to make a mess of the driveway.

This is where I really started getting mad since I not only had to lose the use of the truck, but I had to pay for it too.

4) 36700 My passenger door handle broke.

5) 36950 Air-conditioner compressor seized.

6) 41,200 Won't stay in 4WD. This is where I am now. Still haven't fixed the 4WD problem but hope to have the money soon.


I don't 4WD much (maybe a total of 400 miles) and I have never high centered it. I change the oil every 3500 miles and always let it warm up before driving. I would say that it has been well cared for. Is this normal? My friend has a '94 Nissan truck that has been in for: a broken O2 sensor wire, a failed air mass sensor (whatever that is) and a bad starter. It has about 140,000 miles on it.
 

·
Un-Blown Fake ZQ8
Joined
·
3,401 Posts
Sorry to hear your having so many problems.. I had a Toy before my S10 also.. I now have a 99 4.3L only mine is 2WD. in 45,000 miles I havent had a single problem with it. <Knocking on wood> .
Starter sounds fine, I know its usually one of the first things to go though.
No probs with A/C (I probably use it twice a week in the summer just so it doesnt stop working)
No leaks at the tranny yet. (2wd)
I change the oil every 5000 miles. <-- If you want to know why I'll tell ya.
Has yet to see the dealer...
Yours must have been built on a Monday :cry:
My Toy had 270,000 miles on it when I "traded" it in... Only thing I replaced on that was radiator and shocks.. I drove that thing across country with 220,000 on it :)

btw: Dont bother telling me I'm crazy for not changing my oil every 3,000 miles... Your crazy for doing it so often. :)
 

·
little pink pink
Joined
·
5,036 Posts
Twinjet21 said:
I have a '99 S-10 and have had some problems. I would like to know if this is typical of the S-10 or if mine is just a problem child. My last car (a toyota) went 123,500 miles with only 3 visits to the shop(I do most of my own routing maint). I love the appearance of the truck but the upkeep is killing my bank acct.

1) at 12,300 miles my starter went bad.

2) at 17,000 my tranny started to slip.

3) at 29,000 my tranny began leaking fluid. Not much, but enough to make a mess of the driveway.

This is where I really started getting mad since I not only had to lose the use of the truck, but I had to pay for it too.

4) 36700 My passenger door handle broke.

5) 36950 Air-conditioner compressor seized.

6) 41,200 Won't stay in 4WD. This is where I am now. Still haven't fixed the 4WD problem but hope to have the money soon.


I don't 4WD much (maybe a total of 400 miles) and I have never high centered it. I change the oil every 3500 miles and always let it warm up before driving. I would say that it has been well cared for. Is this normal? My friend has a '94 Nissan truck that has been in for: a broken O2 sensor wire, a failed air mass sensor (whatever that is) and a bad starter. It has about 140,000 miles on it.


I think you have a lemon...
 

·
Un-Blown Fake ZQ8
Joined
·
3,401 Posts
I believe depending on where you live 9 "serious" problems = a lemon. I mean starter dead after 12,000 miles??
 

·
ZQ8 Sonoma Owner
Joined
·
91 Posts
I'd also say it was a lemon. Keep documents on all this stuff thats went wrong on it. If its proved to be a true lemon, GM will have to buy it back from you. You might want to look into that.


Greg Groves
 

·
2 Da Xtreme
Joined
·
360 Posts
T R U C K P R O B S...........!

I had a 94 S10-SS.....and i drove it to 122.203.X
and only had probs i had with it were under 36.XXX
miles.......!
I didnt abuse the truck but i
didnt BABY It either...........!
Ihad to have the fuel pump in the tank
replaced and the power steering pump
replaced.!
I agree with the other guys....
keep records of what you are having
to fix.......!
Does sound like a Lemon.!
I know.....no one wants one......!
Hope Things get better........!
 

·
Deadbeat
Joined
·
1,331 Posts
dont feel bad i have a 00 s-10 xtreme v6 and i've had a bad blower motor 2 different oil leaks faulty tire (or wasnt mounted right) horn stopped honking loosness in the steering wheel (i could pull the steering wheel out an inch...and the steering wheel itself was loose:rolleyes: ) 2 blown shocks and the engine currently likes to tap (its a tap that the gm dealer cant hear too)

oh well

ps i baby mine too
 

·
drag~N~spark
Joined
·
9,530 Posts
darn bro that sounds bad. i hope u get the problems fixed~and do like the other peeps said keep records of anything that has to do with your truck. besides all of that, welcome to the forum...enjoy your stay!
 
1 - 8 of 8 Posts
Top