S-10 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
302 Posts
Discussion Starter #1
Well I just got back from getting the frame welded, and as soon as I got back I started smoking, and oil was all over the engine bay..

I have no idea where it is coming out from, and I will go get pics right now.
 

·
Tech Mod
Joined
·
30,700 Posts
sucks to hear. what truck do you have? 2.2 or 4.3?
 

·
Works too much!
Joined
·
4,679 Posts
Well I just got back from getting the frame welded, and as soon as I got back I started smoking, and oil was all over the engine bay..

I have no idea where it is coming out from, and I will go get pics right now.

see you should have sold it to me...:rotf:
 

·
Registered
Joined
·
302 Posts
Discussion Starter #6
A bolt went into the Oil Filter.. wtf?

How close is everyones mounts from there oil filter? Mine is on it, wtf?

So it wasn't the engine it was the oil filter being busted.
 

·
SLASH - S.I.C. St. Louis
Joined
·
2,440 Posts
A bolt went into the Oil Filter.. wtf?

How close is everyones mounts from there oil filter? Mine is on it, wtf?

So it wasn't the engine it was the oil filter being busted.
who the fuk did you have do your bag job? You didn't go to untouchable kustoms in Belleville, IL did you?

Thats all screwed up man... on the 2.2 there should be no air management bolts close to the oil filter...

pics will help
 

·
I'm Cooler Online
Joined
·
198 Posts
Soooooooooooooooooo, did it restart with a new oil filter? Did it bust right when you got home, or did you drive it with the blown filter and no oil pressure?
 

·
resident crybaby
Joined
·
1,517 Posts
Soooooooooooooooooo, did it restart with a new oil filter? Did it bust right when you got home, or did you drive it with the blown filter and no oil pressure?
lets hope he didnt do that
 

·
Registered
Joined
·
302 Posts
Discussion Starter #10
I was pulling into my friends house, and looked in my rear view mirror and saw a bunch of water (what I thought it was) then I started smoking really bad, and oil pressure dropped like crazy, so I cut it off really fast thinking that my radiator busted or something, so I looked under the hood, and oil was just going everywhere..

Oil Filter got hit by one of the Motor mounts and it busted, no internal damage. (I don't think drove it 200+ miles today) will get pics, dad will be here in a bit, we cut the screw but you will beable to see it.
 

·
Tech Mod
Joined
·
30,700 Posts

·
Useless posting member
Joined
·
10,828 Posts
If it was a busted radiator, your temperature gauge would have skyrocketed - it would have nothing to do with your oil pressure :haha:
 

·
Registered
Joined
·
302 Posts
Discussion Starter #14
the bolt is always on it but we cut the bolt lol.

and thats the exact same place as mine was also.
 
1 - 14 of 14 Posts
Top