S-10 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Alright I have a 2000 GMC Sonoma 2.2L with Automatic transmission.
My problem started whenever I would stop at stoplights or stop signs etc. as I would go to pull out and the truck would drive like it was in neutral making me have to put it into low gear to go. Now the truck has to be in either drive one or drive two to go anywhere at all as regular drive and drive 3 just drive like its in neutral. However, when I get the truck up to speed it will go into drive 3 and 4 but manually. I've checked the transmission fluid with it running and found it was low so I had to put new fluid in but this had no effect at all. Another thing I have noticed however is there is a leak coming from my transmission. I don't know what to do or how to fix this, please helpp
 

·
Registered Hoosier
Joined
·
4,774 Posts
You are probably looking at a trans rebuild or replacement.
 

·
Registered Hoosier
Joined
·
4,774 Posts
You are probably looking at a trans rebuild or replacement.
You have a problem with the forward clutches. When you put it in man low, you are engaging another set of clutches.
 

·
I hate thieves
Joined
·
532 Posts
This exact thing happened to my 94. Rebuild my friend. Rebuild.
 

·
Registered Hoosier
Joined
·
4,774 Posts
You are using manual low already. That is the only way around I know of. Needs rebuilt.
 

·
Registered
Joined
·
473 Posts
why not try removing and inspecting the valve body first? and also testing the solenoids too? you maybe be surprised as to what you may find wrong. a worn or dirty valve body will cause lots of different problems. and so will bad solenoids....
 
1 - 7 of 7 Posts
Top