S-10 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3,094 Posts
Discussion Starter #1
I know this should go in the tranny section, but I will post it there too...

On my way home today, after I got off the freeway, I got stopped at a light. No big deal. I took off normally from the light, wasnt racing, didnt go speeding away. I hit about 50 and let off the gas like I usually do, and it felt like the tranny slipped into neutral for a second, then popped back into gear. Its done that a time or two before but never on a consistant basis. Any ideas?

I have a 2001 4.3L Auto. It has almost 32,000 miles on it.

Thanks for your help!
 

·
Medium Pimpin'
Joined
·
2,403 Posts
y2k xtreme said:
yeah, quit beating the hell outta the truck:bah::bash::D
drow, and that's the pot calling the kettle black
 

·
FLAVOR FLAV!!!
Joined
·
344 Posts
My friends 95 4cyl auto would do something like that. He had to have it rebuilt 3 times because it kept doing this and the place wasn't fixin it right. When you would get on the gas kinda hard sometimes it would pop out of gear redline, then pop back in and he'd be doin a burnout at 50 mph. I don't know exactly what the problem is with them but, i would suggest taking it to a shop or a friend that knows somethin about trannies.
 

·
Registered
Joined
·
508 Posts
Ive been hearing the '97 and later 4L60Es have weak valve bodies.
 

·
The Primered Panther
Joined
·
313 Posts
Yeah I heard that they had weak valve bodies to...Mine's slipping pretty bad right now but I'm just looking for a wreaked Z-28 and drop in the engine, tranny and rearend!!!:uhoh: :evilg:
 

·
Registered
Joined
·
211 Posts
97SS-10 said:
Yeah I heard that they had weak valve bodies to...Mine's slipping pretty bad right now but I'm just looking for a wreaked Z-28 and drop in the engine, tranny and rearend!!!:uhoh: :evilg:
I had my damn valve body go out.. I think it was 400+ for parts...:(
 

·
2 Litre Terror
Joined
·
1,964 Posts
welcome to the world of the 4L60E. It sucks. Dealer told me that you will sometimes catch the tranny in mid thought about were it should be or wants to be. A lot of the tranny is controlled by algorithyms and they arent perfect. was told this was occasionally normal. Sometimes if I start off in D the truck will pull normal through 1st and than when it shifts it pulls like a ******* even though throttle position hasnt changed. Computers...They belong on a desk....not in my truck lol
 

·
Registered
Joined
·
128 Posts
Why don't you take the truck to your local dealership to have the problem covered under warranty? 36 months/36,000 miles. You said yur at 32,000 miles and an 01' that puts you still under manufacturers warranty. I took my 01' with 9,000 miles in to my local dealer this week to have the rear diff fluid changed and the mechanic noticed the rear pinion seal was leaking; they put it in for warranty claim.
 
1 - 10 of 10 Posts
Top