S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter #1
Everytime I punch it from a Dead Stop it Hesatates then catches and Takes off. When I'm moving and punch it it does fine. I've mest with my idel a Little. Could my idel be the Problem?
 

·
Freak of Nature
Joined
·
41 Posts
I had a similar problem on my camaro. It can be a number of different things so you have to check them all. You might need a lighter spring set in your distributor so your timing advances quicker. There is always the problem of too much fuel or too little fuel. It may be flooding or starving. It could also be that your cam is for a different RPM range and you need a new stall converter. It s hard to say without more info. Sorry.
 

·
Registered
Joined
·
618 Posts
If it is a carbed engine...

... Check the accelorator pump settings. If it is a holley you can change the position of the little plastic cam on the throttle lever or you can buy a set of new cams with a variety of different profiles. If it is an Edelbrock I'm pretty sure that all you have to do is change the position of some linkages, I'm not sure where I've never owned one. If its not a holley or an eddy I have no clue. But then again it may not be even carb related.
 

·
Registered
Joined
·
242 Posts
Discussion Starter #7 (Edited)
Man I dunno what size cam I have. I didnt put the engine together.
 

·
Registered
Joined
·
65 Posts
Clay_SS said:
Everytime I punch it from a Dead Stop it Hesatates then catches and Takes off. When I'm moving and punch it it does fine. I've mest with my idel a Little. Could my idel be the Problem?
Check for a simple vacum leak. Start it up and spray a 'little' starting fluid around the manifold and carb. If the engine revs you have found your leak. This can cause the same problem.
 
1 - 8 of 8 Posts
Top