S-10 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
So I removed and replaced the timing chain on my 1996 4.3 v6 S10 with no issues, but, when I watch videos on reinstalling the cover, nobody mentions the rubber strip that sits at the bottom of where the cover slides inside! I have no idea how to get the cover on with that rubber there (which can come out but it’s supposed to be there). I’ve already broken a cover in the process of trying to shove it on in a million different ways so I’m at a loss at the moment. Any suggestions?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
So I removed and replaced the timing chain on my 1996 4.3 v6 S10 with no issues, but, when I watch videos on reinstalling the cover, nobody mentions the rubber strip that sits at the bottom of where the cover slides inside! I have no idea how to get the cover on with that rubber there (which can come out but it’s supposed to be there). I’ve already broken a cover in the process of trying to shove it on in a million different ways so I’m at a loss at the moment. Any suggestions?
I even tried putting the old one back on to see if it was a fitment issue, but that also didn’t fit.
 

·
B4U Task Force Admin
Joined
·
30,336 Posts
Pics are helpful.
 

·
Premium Member
Joined
·
2,159 Posts
You are supposed to drop the oil pan down to allow for clearance. I took and shaved the back corners of my cover down to help slide it by. I still leaked for me no matter what.
 
1 - 4 of 4 Posts
Top