S-10 Forum banner

1 - 7 of 7 Posts

·
crazy gearhead like woaaa
Joined
·
29 Posts
Discussion Starter #1
i have a 93 4x4 dime, we just gothit by snow so i had to get it back together cause the fire chicken dont go in the snow. anywho was puttin a timing chain in it and didnt want to go through the hell of droppin the oil pan to get the cover back on. i tooko tin snips and cut off bout 90% of the inner lip of the bottom of the cover. then i filed it smooth and finished it off with a hammer back into shape(the tin snips distort part of it). i had to slip the bottom of the cover onto the front seal first then sorta pry it upward but it wouldnt go. found once you get the bottom to seat you press the whole cover down towards the pan and it slides right on and still seals well. i removed it and put the gasket to the block on and to be safe ran a bead of black rtv on the bottom of the cover and the seal. reinstalled and smoothed the rtv with my finger works mint. i normally wouldnt suggest this but it is hell on these trucks when 4x4 to put a timing chain in them, i will replace the cover with a new one when i put the new built engine in.
 

·
98 4.3 V6 5 spd black ext
Joined
·
82 Posts
Amen.

Man, I SO feel your pain. I just recently replaced the timing chain on my 98 S10 4.3. It's the most difficult pain-in-the-ass thing I've ever done on a vehicle. I didn't have to remove the motor, like the Chilton manual tells you to, but it probably would have been easier. I unbolted the motor mounts, jacked up the motor, dropped the oil pan the 4-5 inches that I could, and just ran my hand back into the oil pan to fish the new seal around the oil pump pickup and around the edges. Took me 4 hours an extra set of hands, and cut up wrists and arms just to get the new seal around the oil pan. I'll NEVER do it again.

What's worse..turns out the timing chain wasn't even the problem!!!
 

·
crazy gearhead like woaaa
Joined
·
29 Posts
Discussion Starter #3
yah my timing chain was w00ped, had like 3/4 - 1" of play, 4.3's always idle ruff so i swapped out the chain and she smoothed out way better than before, still need to switch back to a/c plugs, i have msd ignition with bosch platinum + 4's, they work well but i think switching back to normal plugs and opening the gap up to lke 50 will work better, cant gap them platinums and the msd will work better with a bigger gap.:idea:
 

·
98 4.3 V6 5 spd black ext
Joined
·
82 Posts
Mine had quite a bit of play in it as well, so seeing as how the motor had 135k+ miles on it..I didn't feel TOO bad.
 

·
crazy gearhead like woaaa
Joined
·
29 Posts
Discussion Starter #5
yah some play is good, when u can almost lift the chain off the gear its no gooda, but this avatar is berry gooda:cs:
 

·
ask me about my crabs
Joined
·
81 Posts
I am not sure on these, but i know on small blocks when your trying to get the cover off just undo the few front bolts of the oil pan to give you some slack, then you can work the cover off, then again i guess on the 4x4's you aren't going to get those off, so go you
 

·
crazy gearhead like woaaa
Joined
·
29 Posts
Discussion Starter #7
yah the oil and tranny lines all run down the pan and theres the 4 wheel drive and cross member parts, total night mare.
 
1 - 7 of 7 Posts
Top