S-10 Forum banner
1 - 20 of 933 Posts

·
TIKI SWITCH GOD
Joined
·
1,417 Posts
Discussion Starter · #1 ·
Well my poor truck went in for an air ride install at a so called good shop about
1 year ago.. since then i now new a new frame cause mine is twisted, bent, and sagging.
The air ride install was lets say less then par.. so it is time for a new one..

Project ouline -
1 - get new frame and strip it
2 - install SD's 5 link kit
3 - Paint
4 - Swap my body onto new frame...

Pics of it so far...

Day 1
Project truck arrives
 

·
Sprint Car Addict.
Joined
·
10,225 Posts
i love your truck dude....you should paint or powdercoat the 5link the same color as the truck.
 

·
TIKI SWITCH GOD
Joined
·
1,417 Posts
Discussion Starter · #17 ·
Thanks for all the comments.. Makes me want to work faster..

Well all that got done last nite was the passenger shock mount and had to remake some cab mounts...

very soon for paint... I was think of paint the frame an Inigo Blue or Viper Blue... and painting the link bars the same colour as the truck...

If i can get some more money i want to get the 5link airbrushed to look like Bamboo but we will see...
 

·
Sprint Car Addict.
Joined
·
10,225 Posts
BLUESONOMA said:
If i can get some more money i want to get the 5link airbrushed to look like Bamboo but we will see...
that would be fucking awesome!!!!! :eek:
 

·
TIKI SWITCH GOD
Joined
·
1,417 Posts
Discussion Starter · #20 ·
Here is some background on my air ride setup

When i first got the truck back the air lines in the front were
ziptied to my a/c hose on one side and some thing else on the other
when i took it back the NEXT day and told them to hard mount them
they mount them to the fenders with three DIFFERENT U shaped
clips... and left everything that they had moved loose under the hood..
windsheild washer tank and coolant tank .. loose sitting on the fenders..

Two days later i took the truck back again cause i noticed that my
airlines where resting on my exhaust manifoulds... and they were melting...
so they ZIPTIED them to some shit so they would not touch the exhaust
anymore... then i for some reason which i can not even understand myself i
when back and got them to run air lines for my gauges... well they lasted 2 days then exploded on the highway doing 100 kms.. with no front bags "0 psi" and lots of sparks.. so back agian i went.. and they said they fixed it.. that nite they blew again .. so back agian i went and they told me my engine was running to hot and there was no were else to run the lines.. that i was basically "shit out of luck"..
but they did put in new lines in the SAME SPOT thanks guys... really helped

So i when got home.. i called a buddy and he ordered me some 3/4" insulated hose that they use on Transport trucks and reran my air line thru that.. for some heat protection... and then we look at the engine for like oh 5 MINUTES and found
a new spot that the shop could not find.. THE FENDERS.. away from my engine that was running to hot but never overheated...so we reran the line thru
the fenders and TADA my air lines have not blow in a year.. So with my 5 minutes
of experence on running lines I did better then a shop... whatever.. and they told me a got a great deal on my install price... Thanks for the ZIPTIES..

Well my story is done thanks for reading it... sorry it was so long
 
1 - 20 of 933 Posts
Top