S-10 Forum banner
1 - 20 of 21 Posts

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #1 · (Edited)
ive emailed back and forth some with pork, and kris bout a problem im having.. heres what i sent them.. since everybody on here knows everything about anything, i wanna see if the NON-SD guys say the same thing the 2 experts said.. then, i need jason, dave, kris, or pork to hook me up with a total price on everything i need!!

i have a universal triangulated 4 link, bars over axle on my o2 2dr blazer, and i fkin hate it.



when i am driving down the road, the entire truck starts shaking like i am hitting sides.. and i dont even have sides lol not a vibration.. today when i drove it, it felt like the ass end was fishtailing on me

im to the point now where i want to throw away the 4 link, and just build a 2 link. EVERY bagged truck I have ridden in with a 2 link is caddy compared to mine.

any suggestions on why it might be doing this..

and can ya get me a price on some things.. for some reason, at work i cant access SD.com




if ya can.. please price:

wheel tubs (22s on the back of the blazer with a 255 30 22 (maybe 35) cant remember, sorry

notch cover

50ft 1/2 OD line

bag brackets, and bushings, and whatever else i would need for bags on the lower bars.. a wishbone is even beter than what i have

if you need any measurements, let me know..

if ya can help, THANKS.. if not.. no biggie
 

·
Shit's Weak
Joined
·
1,970 Posts
could that shaking be caused by:
only a 2 valve rear setup?
having the bags too close together on the rear axle with no shocks?

i'm not sure, but your problem can probably be fixed by someone who knows whats up. post up some pics of your setup in the baggin it section and maybe someone can help.
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #3 ·
nope.. has shocks.. just pulled the rear ones off, and they are still good
 

·
2.2 Auto FTW
Joined
·
2,957 Posts
it sounds to me like the link is outta whack and is causing the truck to sway the ass end around and maybe the pinion angle is messed up or something to make it shake so hard
 

·
!! TALK NOW !!
Joined
·
4,910 Posts
i would have to think that something is not tight.. I ran into a problem about the swaying once.. only under braking tho... the ubolts were not tight... not i ain't sure if you welded them on or bolt on.. also.. might be off center and the u joints are making it vibrate because off center

do you know if your dogleging?

i don't think its the kit.. i'd have to say wrong instillation

o yea.. another idea.. say you didn't have the mounts to the bushings snug to the bushing itself when welded up.. this may allow slop and cause the swaying... just ideas

but all is incorrect installation
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #7 ·
goin now to take pics :) from what i can underneath with the rear on jackstands....... lol
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #10 · (Edited)
wow... no pics... i realized that the lower bars.. the heim joints have been drug through haha.. i think now im gonna buy the bushings, and tabs, and more airline to replumb the whole thing, and let the shop who did it fix it. the shop told me today that he wants to reverse the top bars.. right now, my setup looks like this:


V
I I


he said if we change the top bars from V (pumpkin to frame) that it might help out alot

which would make it:
A
I I

but that means i still have bags over the axle.. it will allow me to untuck 20s.. MAYBE 22s..
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #11 ·
MoneyMike said:
pffft... come over asswipe.. i wanna see your truck
 

·
get on my level
Joined
·
232 Posts
yeah mine does the same thing man...when i left it above tires it rides fine but bumpy.when i ride low it sways like ****!!! an i have a


v
l l
 

·
bitch
Joined
·
7,884 Posts
onmylvl said:
yeah mine does the same thing man...when i left it above tires it rides fine but bumpy.when i ride low it sways like ****!!! an i have a


v
l l
your shits about to fall apart dude thats your problem, i wish id taken pics of your 4 link bolts FALLING OUT. i dont care if the sole purpose is dragging atleast make it safe. your shit was hacked
 

·
5 inch bodydrop bitches
Joined
·
1,651 Posts
maybe your bars arent triangulated enough and the frame is moving side to side. you might need to get a panhard bar or a watts link. thats what i did.
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #16 ·
im already looking at replacing the lower bars with 2x2 and but the bags on the bars instead of the axle.. its like im gonna have a 2 link with a triangulated top setup.. i feel like im combining a 2 and 4 link
 

·
is back...
Joined
·
1,072 Posts
LaynLo17 said:
your shits about to fall apart dude thats your problem, i wish id taken pics of your 4 link bolts FALLING OUT. i dont care if the sole purpose is dragging atleast make it safe. your shit was hacked
:haha:
 

·
ERRATIC.. erraticclub.com
Joined
·
360 Posts
Discussion Starter · #20 ·
s10st said:
2x2 with busings on both ends.........lower 4 link bars not a damm 2link you ass:D
well hell shawn.. i keep hearing my top bars are backwards, and maybe i need a panhard bar.. i know what you say, but if the top bars are on backwards, then im fawked.

the bars are in front of the axle, but V on the axle.. ive measured them all and they are even
 
1 - 20 of 21 Posts
Top