S-10 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone! My son and I have been just on the fence with this problem and like so many of you, we replaced everything! Let me tell you, that truck really came alive but! We still had P0301 and then it hit use after we did the compression test? what if its a simple valve lash adjustment! Boom mic drop! Pop that cover and get to adjusting, problem solved. Look it up on YouTube it is really that easy. We hope our crazy hair pulling event helps. ⚠ Caution if you keep driving on it you could cause more damage to the valve components because of a simple valve adjustment.
 

·
Been there Done it
Joined
·
14,398 Posts
You talking bout the dreaded SBC cam lobes? 1st gen would be flat lifters in most cases. :confused:
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Year and engine would help.
The year is a 99 s10 6cyl, my son also stated that ever since this he started to put 89 to 91 octane fuel and has made a difference the truck idles like its off.
Hello everyone! My son and I have been just on the fence with this problem and like so many of you, we replaced everything! Let me tell you, that truck really came alive but! We still had P0301 and then it hit use after we did the compression test? what if its a simple valve lash adjustment! Boom mic drop! Pop that cover and get to adjusting, problem solved. Look it up on YouTube it is really that easy. We hope our crazy hair pulling event helps. ⚠ Caution if you keep driving on it you could cause more damage to the valve components because of a simple valve adjustment.
My sons trucks vin number is an X style I know this made a difference when we replaced the motor so that may also very from motor to motor?
 
1 - 6 of 6 Posts
Top