S-10 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4,856 Posts
Discussion Starter · #1 ·
i might know the answwer to it but thought id post to see if anyone had any other things that i can check.

my tranny shifts really late at cruising speeds (not WOT runs) 1st to 2nd isnt too bad and shifts about 3000. but 2nd to 3rd just doesnt happen unless i get it up to over 40 or so when before it would if i was just cruising along. then it will click into 3rd if at all. im thinkin that i might have a vacuum leak to the modulator or maybe the line got kinked when i reinstalled it. i havent looked yet but thought if make a post to get any more suggestions of what it could be unless thats not it.

any one have any ideas?
 

·
Registered
Joined
·
471 Posts
if your tranny was workin fine before and your using the same converter and you havent changed anything on the tranny id say check out your modulator valve and vacuum to it first
 

·
Registered
Joined
·
4,856 Posts
Discussion Starter · #4 ·
yea im pretty sure thats all it is. just thought id see if it could be anything else
 

·
Registered
Joined
·
35 Posts
could be burned direct clutch plates,3rd gear, friction material worn off the discs. Transmission must be torn down if this is the problem. try to get moving to about 35-40 mph and shift to neutral ,then pull back down in gear.
 

·
low country dropshop
Joined
·
1,653 Posts
if all of these other ideas above me dont work, try this......

pull it into 1st gear and take off down the road and around 3500-4000 RPM's, shift it into 2nd gear manually and see if it changes immediately. If it doesnt, come to a complete stop and put it back in 1st gear and take off again. This time when it gets to 3500-4000 RPM's change the radio to 93.7fm and shift into 2nd manually again. if it still doesnt change, take it to a shop via rollback immediately.

but seriously, id say modulator valve probably
 

·
low country dropshop
Joined
·
1,653 Posts
superunknownmoto said:
C'mon now. Everyone knows you need to change the radio station to 107.3, not 93.7. We learned that in Auto Shop 101in 9th grade.
.


damnit....i think you may be correct:cool:
 

·
Registered
Joined
·
1,229 Posts
yeah i would also check to see if it has a spring behind the modulator. alot of people take it out so it shafts later and firmer. its a easy and free way to try to have a performance tranny. if you want a b&m adjustble modulator still sealed i have one ill sell ya. i bought it, but my shift kit came with the stuff to rebuilt to stock one so i didnt use the b&m one. its adjustable for different mph shifts. just pm me if your interested.
 
1 - 10 of 10 Posts
Top