S-10 Forum banner

Status
Not open for further replies.
461 - 480 of 491 Posts

·
Registered
Joined
·
14 Posts
Hi !!

I'm trying for a long time now to find what's the problem :rant:
My 1996 jimmy 4.3 drinks too much fuel , it's consumes WAY too much fuel.
Ex : With 80$ ( +or- 14 gallons) .... I can barely drive 180 miles !
It's around 13 MPG :eek:

The tune up is done from A to Z (wire , spark plugs , Rotor , Cap , Air filter , Fuel filter .... )

The only thing I did not change so far on the tune up are the o2 sensors .

Brakes are not stuck .... Engine goes well .... No fuel leak , no leaking injectors (I removed the intake to check it) ...... Can't figure what it could be !! Any help would be appreciated!!!

thanks
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
#1 Start a new thread
#2 Start said new thread in 4.3l forum not the 2.5l Iron Duke Forum
#3 Check your fuel pressure and post all your above info into that forum.
 

·
Registered
Joined
·
33 Posts
I need help got a iron duke motor from a rebuilder is washington and put it in my truck and it leaks oil in the back some where, it looked like the plate i took it off and resealed it and it wasnt that, im stumped man. and the temp. gauge plug in the back of the block what does that plug look like?
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
Not to be rude or redundant, start a new thread. This one is old and should be dead.
 

·
WWW.CAROLINATRUCKSCENE.
Joined
·
2,158 Posts
not to brag, just here to help... any questions or unsolved mysteries? i can just about answer anything about these little engines- i love them, i have owned 23 lol -
ok heres one for you, that i think i figured out but lets see what you think.

88 S10 standard trans, 2.5. when i was working at my friends garage another friend brought this truck to me. new problem came, it started stalling out every now and then, and then it was a regular problem, when it warmed up, and got up to about 55 mph, the shift light would pop on, and it would stall out and you wouldnt be able to start it for atleast a half an hour. he replaced fuel filter, plugs before bringing it to me. luckily there was a boneyard in our town that my boss knew the owner pretty well, so we swapped out the dist, ecm,, and after my friend didnt want to dump any more into it he gave up and sold it to me for dirt cheap. what your oppinion.
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
Not to be rude or redundant, start a new thread. This one is old and should be dead.

I think the Dukeman is gone, or DOA. RIP IRONDUKEMAN
 

·
WWW.CAROLINATRUCKSCENE.
Joined
·
2,158 Posts
Not to be rude or redundant, start a new thread. This one is old and should be dead.

I think the Dukeman is gone, or DOA. RIP IRONDUKEMAN
so what your saying is no one has an answer for me??
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
NO, saying this is a long dead thread, start a new one so if some answers come to you that it will be easier to understand than a thread with 500 posts and 200 questions especially if someone else is having trouble too then they can look for the title and say "hey thats what mine is doing, wonder what they found out." Like I said not trying to be rude, this thread is dead it is easier to troubleshoot and answer a small thread.
 

·
Registered
Joined
·
250 Posts
I've got a 88' short bed std. cab. With a 2.5 5spd. How many horse's or should I say. Lack of horse's doe's the two five put out. I just installed a new catylic converter and a 40 series Flowmaster. Boy it sure didn't sound like I expected it to.:p
 

·
Registered
Joined
·
122 Posts
heres one for ya knowlege... The lil sticker on my fan shrouds decayed to the point its unreadable...

Whats the timing suppose to be set at on an 87 2.5L l4... and all my repair manuals just say to "read the tag under the hood".. but like i said my stickers are all decayed under there...
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
Veteran, duke rated around 95HP.
Batty, all GM 4 cyl are 1,3,4,2 firing order.

START A NEW THREAD, lets not clog this one up furter.
 

·
Wire Splicin Fool :-)
Joined
·
8,692 Posts
8* With A/B terminal on ALDL jumpered, been mentioned in other threads ALOT, the search function leaves a lot to be desired, but it does work.
 

·
Registered
Joined
·
2 Posts
Well let me start out by saying I have a 89 s10 l4 standard transmission

When I first got the truck, it started but shuttered very hard until the truck began to idle high and gradually smooth out! It had a lot of drag when I drove it home which there it sat until I began to work on it

My dad and i manually set the first piston to TDC on the compression stroke today to check the timing because we figured the previous owner just got the timing all whacked out! So we start it up BEFORE we try to time it and everything sounds smooth and better than before, we then base timed the engine and then cut it back off to tighten everything down, and now when we start it back up, IT SOUNDS JUST LIKE BEFORE IF NOT WORSE! AND THE DAY ENDED WITH THE TRUCK NOT WANTING TO KICK OVER ANYMORE !

One second its runs like a champ, and the next it doesnt run at all!!! Any ideas? IS IT THE TIMING OR WHAT???

While I was in there I also checked out the:EGR,and changed the spark plugs (except for 4) cause my dad thinks its stripped out!!!
 

·
Registered
Joined
·
2 Posts
Well let me start out by saying I have a 89 s10 l4 standard transmission

When I first got the truck, it started but shuttered very hard until the truck began to idle high and gradually smooth out! It had a lot of drag when I drove it home which there it sat until I began to work on it

My dad and i manually set the first piston to TDC on the compression stroke today to check the timing because we figured the previous owner just got the timing all whacked out! So we start it up BEFORE we try to time it and everything sounds smooth and better than before, we then base timed the engine and then cut it back off to tighten everything down, and now when we start it back up, IT SOUNDS JUST LIKE BEFORE IF NOT WORSE! AND THE DAY ENDED WITH THE TRUCK NOT WANTING TO KICK OVER ANYMORE !

One second its runs like a champ, and the next it doesnt run at all!!! Any ideas? IS IT THE TIMING OR WHAT???

While I was in there I also checked out the:EGR,and changed the spark plugs (except for 4) cause my dad thinks its stripped out!!!
 

·
Registered
Joined
·
250 Posts
I've got a 88' S10 std. cab. short bed. 5speed 2.5 my question is this. How much horsepower (lack of) doe's the 2.5 put out! My 40 serie's definately don't sound off like it should... Flowmaster suggested to have at least 160 horse's or better. Would a K&N,Tornado and maybe a performance injector do the trick? I'd like to keep the 4 but if not I'll go to either a 2.8 or 4.3 V6 Thanks Sam B Elyria,Ohio:(
 

·
Registered
Joined
·
122 Posts
I've got a 88' S10 std. cab. short bed. 5speed 2.5 my question is this. How much horsepower (lack of) doe's the 2.5 put out! My 40 serie's definately don't sound off like it should... Flowmaster suggested to have at least 160 horse's or better. Would a K&N,Tornado and maybe a performance injector do the trick? I'd like to keep the 4 but if not I'll go to either a 2.8 or 4.3 V6 Thanks Sam B Elyria,Ohio:(
for 88

2.5L's had an output of 92hp/132 ft-lb

2.8L 125hp/150 ft-lb

4.3L 150hp/230 ft-lb
 

·
Registered
Joined
·
7 Posts
Ok here is my question. I have an 87 4x4 with a 4 spd man. and a 2.8, I would like to drop a 2.5 in it. What kind of advantages/ disadvantages will I have with this setup?
 
461 - 480 of 491 Posts
Status
Not open for further replies.
Top