S-10 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have a kenwood excelon deck and i Rocford 200 watt amp (that pushes 320 watts) and a rocford he 10 inch sub. my stock alternator recently went out and i purchased a remaunfactured one. but it went out also. now i have another remanufatcured one. but i called around and was told my system could be causing this prob(they said older GM alternators what this problem) they say ill need a proformance 200+ watt alternator. this is very expensive. what other alternatives so i have so i can have my bumps back? (and still be in motion) HELP?
 

·
Registered
Joined
·
3,105 Posts
mbeef61 said:
I have a kenwood excelon deck and i Rocford 200 watt amp (that pushes 320 watts) and a rocford he 10 inch sub. my stock alternator recently went out and i purchased a remaunfactured one. but it went out also. now i have another remanufatcured one. but i called around and was told my system could be causing this prob(they said older GM alternators what this problem) they say ill need a proformance 200+ watt alternator. this is very expensive. what other alternatives so i have so i can have my bumps back? (and still be in motion) HELP?
Put a capacitor on it, that will help take some of the strain.
 

·
V8 needin' member
Joined
·
424 Posts
yeah do a one farad cap. but i dont think that just that one amp is going to be drawing enough current to toast your alternator... but a capacitor or a second battery would be the way to go
good luck man
 
1 - 3 of 3 Posts
Top