S-10 Forum banner

1 - 6 of 6 Posts

·
Entoxicated Hoodlum
Joined
·
105 Posts
Discussion Starter #1
Ok Im dropping in a 10 inch sub and a kenwood mono sub amp on my BRAND NEW '03 this weekend. I need to know the best way to run the constant hot wire to the amp from the battery? Is there an easy way to do this? Is there the best way to do this. Its happening on saturday so I need help.....
Thanks everyone.
 

·
Registered
Joined
·
22 Posts
what guage wire are you running?????? please say 4 guage! either way i did mine from batt back to firewall then accross the engine bay then through the firewall by the steering wheel kinda then under the carpet to the back.
 

·
Entoxicated Hoodlum
Joined
·
105 Posts
Discussion Starter #3
Yeah 4 guage kit is what I have. Is that the easiest way? Did you drill any holes anywhere, bcz I really dont want to go punchin holes through everything.....
Im also installing a center console and a drivers side bucket so running the wires through the cab will be easy. I just need to get it from the battery to the rear of the cab the best way possible.....
Anyone do it differently?
 

·
Show Me Dem Titties
Joined
·
146 Posts
the best way is to go through the antenna hole, on the passenger side, pop off the rocker panel cover, then the kick panel, and pull the carpet and insulation back, almost directly in the center of the slanted part of the floor pan there is a gromet about 1" in diameter with 1 wire going through the center of it (antenna wire), if you are using something less than 4 gauge it will just push right through beside the antenna wire, but if you use 4 gauge then you will need to trim some out of the gromet. once the wire is through you can feed it behind the kick panel and under the rocker guard and you have a professional clean instalation. BTW it is best to shove the wire through from the cab side, because it comes out right under the air box and it hard to get to from the engine compartment but is easy to get when you shove a bunch through from the inside. hope this helps
 

·
Insert catchy saying here
Joined
·
1,311 Posts
Yeah...thats how I ran mine. From the spare positive post they give you back to the firewall, across the bay, down into nowhere it looks like, and then in through the antenna hole. Then if you pop off the little trim right under where the door normally sits, there is a little metal track for that piece to fit in there. Between that track and the outer lip where the outside of the door rests, there's a little groove there. 4GA fits perfectly, it was meant to be....
 
1 - 6 of 6 Posts
Top