S-10 Forum banner

1 - 19 of 19 Posts

·
Resurected
Joined
·
302 Posts
Discussion Starter #1
okay,
so when we bagged my friends truck back in July, we thought one of his compressors had blown up (Viair 550C) cuz it fried the relay right away..... so we sent the compressor in, viair checked it 7 times and sent it back saying nothing was wrong with it..... and it worked.... well today my buddy was going to take one of his finals, and he noticed his compressors sounded a lot quieter.... well the relay on that same compressor fried again!!! and this time it took the ground and the power with it..... the only things i could think of was maybe the relays were not powerful enough, or that one of the wires was exposed and was arking out somewhere, or the fact that he still doesn't have a fuse that's run to the battery.
anyone have any ideas???

ERic
 

·
Registered
Joined
·
345 Posts
Hey!!

Hey, I think I know whats wrong. The relay prolly cant handle constant duty, so tell him to go to an auto parts store and get a constant duty solenoid, and see if that helps.
 

·
Registered
Joined
·
684 Posts
is he running 2 viair 550's?? and running a relay for each compressor?? I believe the max amperage on a viair 550 is 30 amps so if he's running 30 amp relays that maybe why they keep blowing..If thats the case he may have to upgrade to 2 40 amp relays..hope this helps
 

·
Resurected
Joined
·
302 Posts
Discussion Starter #4
thanks guys
i think we'll try the 2 40amp relays.... the wierd thing is that only that one, is the one that's blown twice.... the other ones still fine... oh well i guess we'll find out

ERic
 

·
Registered
Joined
·
684 Posts
I couldn't find 40 amp relays locally when I was looking for them so I had to order them off a website...if ya can't find any, www.partsexpress.com has them for $1.79 each...I also think he should get a inline fuse to run to the battery... probably go with a 80 amp
 

·
Registered
Joined
·
3,813 Posts
I got mine from Napa, but they are mad expensive here...so I got my others from Radio shack...



I have a shitload of extra relay's somewhere in my room...:D
 

·
Resurected
Joined
·
302 Posts
Discussion Starter #9
yeah,
at napa the first time they were like freakin $11 a piece
i think we'll try that guys web site
thanks again man

ERic
 

·
Registered
Joined
·
34 Posts
i had the same prob with my solonoid on my blowjax 3\4 100% duty cycle compressor i dont know what to do
 

·
Registered
Joined
·
34 Posts
will it still cut off with my pressure swtich hooked up to it?
 

·
Registered
Joined
·
34 Posts
i just bought a starter solnoid for a 74 ford f100 hope it works ill let u know
 

·
Registered
Joined
·
13,733 Posts
If its not a continuous duty solenoid, you might as well just take it back and find one that is. If it is already, then more power to ya. Hope it works out for ya.
 

·
Resurected
Joined
·
302 Posts
Discussion Starter #16
the wierd thing is i've got two 550C's as well.... mine are about a year and a half older than his, and i'm running two 30 amp relays on mine, and so far their good. do you guys think a 40amp can handle a 100% duty cycle???
 

·
Registered
Joined
·
603 Posts
A Dumb question....
How are the compressors wired?
Do you have a seperate power wire going to each relay. or is the power for the second compressor coming from the first compressor (The one that burns out the relay)??
Just a thought..
 

·
Resurected
Joined
·
302 Posts
Discussion Starter #18
i believe we just ran the power line from the first comp to the second comp. i'm not completely sure though
 
1 - 19 of 19 Posts
Top