S-10 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
630 Posts
Discussion Starter · #1 ·
ok guys i just baught a 89 2dr 2wd blazer with a 4.3 ... the guy who had it before me replace the throttle cable the day i baught it because it had broke... well now sometimes when i let off the gas the peddle stick closed... well i took off the aircleaner and looked into the throttle body and the butterfly is over closing ... so instead of being completly horizontal when closed it is actuallly going up on a slant a little ... my question is what can i do to fix this.. my dad says take a dremel and grind down the butterfly a little so it dosnt stick closed.. but that seems a little ghetto to me.. what do you guys think
 

·
Registered
Joined
·
630 Posts
Discussion Starter · #2 ·
bump!
 

·
Registered
Joined
·
618 Posts
Well if it is the blade that is hitting the body and keeping it from closing. Pull the throttle body and loosen the screws that hold the blades in place and recenter the blades then tighten the screws. You may also want to put a new bit of loctite on the screws to keep them from loosening up and falling into the engine.
 

·
H-D motorsports
Joined
·
654 Posts
clean the throttle body
chances are it's just a bit of carbon build up.
even my 99 starts to stick shut mildly when the TB is getting dirty.
 

·
loco hombre
Joined
·
3,461 Posts
hardlydangerous said:
clean the throttle body
chances are it's just a bit of carbon build up.
even my 99 starts to stick shut mildly when the TB is getting dirty.
Yep, what he said.

My 96 stuck from the day I bought it, and I finally ripped the intake off and saw the ring o' gunk in the throttle body. Once clean, it never felt sticky again - and still hasn't, years later.
 

·
Registered
Joined
·
630 Posts
Discussion Starter · #7 ·
my problem isnt dirt its closing to much ill try inthebatcaves idea firs t thanx
 

·
Registered
Joined
·
591 Posts
yeah my throttle was sticking a little bit, it turned out i just needed to oil the acelerator pedel.
 

·
H-D motorsports
Joined
·
654 Posts
Disco Inferno said:
I don't quite have that. I've got a 2000 4.3 ZQ8 and when I'm at driving speed, say on the highway, if I let off the throttle completely it sticks a little when I press the gas pedal again.
That's exactly what mine did when i first got it (used) and started doing again a couple years later when it got dirty again.
Clean it and your problems will be over.
 

·
Registered
Joined
·
57 Posts
Mine is sticking open. Could it be the same problem? Came of the highway and almost burned my brakes up. I can push it back easily and start up at idle but when I give it gas it sticks open, Help!
 
1 - 13 of 13 Posts
Top