S-10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
whats up guys, new kid here...... my truck is an 88, 2.4, and 6 cylinders....... when i try to start it, it usually backfires and dies.....then i try the second time and it starts up. ive already replaced al spark plugs, the distributor cap and rotor..... im thinkin it might be the ignition coil, but im not sure.....so, a little help would be appreciated. thx.

:dunno: :phil:
 

·
Registered
Joined
·
517 Posts
First... check your displacement - you're missing about 400cc's. :D

Then, I'd be checking your fuel pressure (changed the fuel filter lately?)
 

·
Registered
Joined
·
517 Posts
s10boi said:
what do u mean, im missing 400 cc's?
The V6's are 2.8's
You said it was a 2.4
2800-2400=400 missing cc's

:nuts:
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
i changed my fuel filter about 2 months ago
.........this truck was under a flood(it used to be my late gravdpa's) and nowi have it. so im trying my best to keep it workin.....when i changed the fuel filter last time. its was almost imposssible to blow through cause it was so clogged.
 

·
Registered
Joined
·
517 Posts
Ok, so back to seriousness....

Has it ever run properly (ditto for starting) since the big flood?

If the filter was so clogged before that you couldn't blow through it, there's a good chance you've crapped out the pump (they don't like to get backed up like that). I speak from personal experience on that one... ahem....

So, before you go on a random parts replacing mission - Check that fuel pressure and volume!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
new question...

my truck idles really high when i have it in park.......and i dont know why.


also, my truck is under alot of strain when i put the ac on, like it want s to di or something.
 
1 - 7 of 7 Posts
Top