S-10 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I'm trying to help out my neighbor who has this problem.
It's a '94 Chevy Blazer 4-dr. with about 99k on the clock. He has a hard time starting it up. It takes him about 4-5 attempts before it'll turn-over and when it does finally startup, it idles rough. It sounds as if the idle fluctuates high and low. He says the only item that's been changed so far is the fuel pump.

What should I look at next????
A) Suggest a tune-up (plugs, wires, cap & rotor, air filter)
B) Check electrical system (battery, alternator, starter)
C) Fuel system (filter, injectors)

Thanks in advance
 

·
Deadbeat
Joined
·
1,331 Posts
does it turn over when it doesnt start or just click or not do anything at all....might be the starter if it doesnt turn over on the first few attempts
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
You can hear it cranking but it won't startup. I don't get any clicking sounds from the starter and battery does seem strong. As I said in my previous post, it takes about 4-5 attempts to get it started and then after it does there is the idling problem. It sound extremely rough when idling.

Thanks for the responses so far. :)
Keep 'em coming.....
 
K

·
Guest
Joined
·
0 Posts
if it is a 4.3 cpi motor..the regulator leaks often on those and cause that problem
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
I mentioned it to him regarding the possibility of dirty/clogged fuel injectors and he replied he'd already run a bottle of fuel system cleaner. It made no improvement. I don't know if he's done anything with the fuel filter.

What gets me is that he says he's taken to 2-3 places locally and they still can't solve the problems. To date, he says he's spent ~$700 trying to fixit. Go figure.

Again, thanks for the responses. :)
 
K

·
Guest
Joined
·
0 Posts
it the regultor leaking...you have to pull the plenum to see it leaking
 

·
MO. boy missing St.Louis!
Joined
·
137 Posts
Me too!

I had the same problem, even after I changed out the Fuel Pump. It ended up needing a new computer and it fixed the problem.
 
1 - 10 of 10 Posts
Top