S-10 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter #1
Alright I've been having an intermittent problem. My truck won't crank I give it a while and it cranks. Well now it won't. Batts good everything has ground and when I jump the starter terminals I get nothing but sparks, no clicks it doesn't even try to start. This starter is a year old. I even jumped straight to the starter strip on the bottom bolt of the starter, nothing.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
175 Posts
Discussion Starter #2
Well I got it to crank this morning, with both bypassing the starter and using the key. I jumped the battery off to do it. What's weird is last night I had had it hooked up to another truck for 30 minutes and it made no difference. It would move real slow and click once or twice and not work anymore.

Could it be the starter binding?
I do currently have 20w50 in it but I haven't had any problems and I even turned the crank to make sure it wasn't seized
The battery is a 1100 ca interstate battery roughly a year old
And the alternator was just rebuild in april
Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
175 Posts
Discussion Starter #3
So it's still not cranking. Another thing is I when I touched the solenoid casing, it's really hot. The starter is find it's just the solenoid. But until it wants to crank so I can get it back to my house I can't do anything. And corrosion has almost eat one side of my pos battery connector


Sent from AutoGuide.com Free App
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
1 Participant
etaomicron
S-10 Forum
S10forum is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!
Full Forum Listing
Top