S-10 Forum banner

1 - 11 of 11 Posts

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #1
my 85 has a 5/6 drop and i have a horrible sqeak in the front suspension... it happens any time the suspension moves and is getting kinda annoying... and Ideas on what it could be and how to make it stop?
thanks:(
 

·
Registered
Joined
·
691 Posts
hmmm, i would guess it is the coil rubbing inside the lower cup or the upper cup in the frame. Maybe, if you feel like taking it all apart, you can get rubber pads that go on the ends of the coils to cushion and make it so it isnt metal on metal.... just an idea
 

·
Bolt-On Body Dropz
Joined
·
2,617 Posts
im not sure what it is, but i know when u put spindles on ur truck they usually come with grease so u can lube some **** up, i cant think for some reason of what it is though
 

·
2 Litre Terror
Joined
·
1,964 Posts
If your running any urethane bushings or spring pads they will squeek like a mother. Best thing to do is lube them with a Marine grade wheel bearing grease. On my eclipse I actually drilled and tapped them for zerk fittings.
 

·
Say lowered d
Joined
·
1,349 Posts
either that or....

your stock rubber bushings are so gone they sqeak. My 64 does that too. If you get a needle grease gun adapter, you can get some grease in there if that's whats doin it.;)
 

·
Registered
Joined
·
2,850 Posts
regular problem on my customers trucks. i just notch the dust shield. if you look underneath the dust shield touches the lower a arm if you use 2 or 3 inch drop spring with spindles. i put a quick fix section on this a few months ago here is the link

http://www.s10forum.com/forum/showthread.php?s=&threadid=3543

read the top thats all you need to do
 

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #7
sweet ass thanks a ton man im gonna try and do that tonight after i get off work ill put another post up here if it works...oh yeah do i need to take the rotor off or can i do it with it on?:D
 

·
Registered
Joined
·
45 Posts
When I did a 3/4 drop on my S-10 it did the same thing. Someone told me to HOSE DOWN the new springs with WD-40. (Being careful not to spray it on the disk brakes.) After about a can it worked. I can't really explain it, but the squeak is gone.
 

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #9
last night i cut those notches in my dust sheilds and I HAVE NO SQEAK!! so now that problem is taken care of thanks a lot .. that was drivin me insane... it was actaully rubbing so much that it wore thru the dustshield on the passenger side!!
thanks again
 

·
Registered
Joined
·
2,850 Posts
no problem i have customers lots of times that have this problem. i had this problem 4 years ago when i lowered my truck the first time eversince then whenever i do spindles on customers trucks i notch the shield glad i could help

tony
 
1 - 11 of 11 Posts
Top