S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
I have a squeakin nose on the driver side and when i get out it squeaks realllly bad,I found its somewere near the tire like a rod or maybe a bushing.My question is what is this and how can it be fixed?It does it on the passenerger side but not as bad..oh when i turn the wheel all the way to the drivers side it doesnt make any more noises.Thanks

Mark
 

·
Registered
Joined
·
1,072 Posts
take a grease gun and grease all your points up front i just did it to mine last week cause it was making a horrible noise it fixed the problem

i think there is 3 on each side while your under there do the other side 2
 

·
I'm on a boat!
Joined
·
1,522 Posts
Are you running drop spindles?? If so, did you trim the dust shield or whatever it is on your ABS?? If you answered yes, then no, you need to do some trimmin.

I haven't trimmed mine, and I HATE that squeak.

:phil:
 

·
Registered
Joined
·
14,881 Posts
it could be the control arm bushings, remove the bolts holding them in, slap some grease on them, and reinstall... if that is even the problem.

also check the body mounts... sounds dumb but you could have a bad mounting bushing.
 

·
Registered
Joined
·
14,881 Posts
well with the new spindles, the dust shield on the back of the rotor can just touch the lower control arm. either trim the dust sheild or simply shove a screw driver in there, and bend the shield another 1/8 away from the lower control arm.. just make sure you dont go to far, then you will rub the rotor.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #8
Ok i greased all the fittings and bushings...i see what the dust sheid is..i bent that back about 1/2''...still making noises =(...i do nt get it..ima go out there and check ever thing from the lower and bottom control arms and just grease everyhing.
 
1 - 8 of 8 Posts
Top