S-10 Forum banner
1 - 18 of 18 Posts

·
amatuer porn star
Joined
·
614 Posts
Discussion Starter · #1 ·
i was trying to cathc up to another minitruck on the freeway yesterday so i could flex on his a$$ but when my speedo hit 95 my truck slowed its self down(it mad a small noise like some kinda computer stepped in or something).

im not sure how fast i was going cause i went from stock rims and tires (215 /75 r 15)
and now ive got 17" rims with a 45 series tire.
 

·
amatuer porn star
Joined
·
614 Posts
Discussion Starter · #2 ·
any one know about this?
 

·
Rollin' Low in the 619!!!
Joined
·
409 Posts
that was your speed limiter kickin alright. mine kicks in around 95 with 225-40-18's. there was a post some where about bypassing it which is all you can do for now without getting a chip from ASC
 

·
amatuer porn star
Joined
·
614 Posts
Discussion Starter · #4 ·
cool ****....damn 2.2 suck ass
 

·
little pink pink
Joined
·
5,036 Posts
murph619 said:
Hey, can you tell me where the info is on bypassing the speed limiter on my s-10? Thanks.
Yea the 4.3's have them as well....
you can get around them by using the HyperTech Programer...
but you can only change it to 130mph max. and it cost like $300. I myself will not spend that b/c I can't hit over 96.8mph in the 1/4mile...so it is waste of money for my 4.3 5speed truck...cuz I still out run trucks that have been programmed(until I hit the limiter)...
 

·
Registered
Joined
·
3 Posts
Yeah, the limiters do suck though, I was racing an older BMW 3 series with mine. Hit 95 and the engine starts screaming "BWAHHHHH!!!!" (it seems louder with the exhaust and intake, plus I hit it pretty hard)

It also sucks on the highway when you are kind of supercruising, in my Honda I always would get up over 100 and just roll, not so with my Chevy girl. with the older styles, some engine management chips will take it off, completely, I still haven't found a chip for my new one though, I will check out the one Xtremer-PXL mentioned. thanks for the tip man.
 

·
Registered
Joined
·
8 Posts
Yah, i found out that it shut off at 95 when i was going to work one day. i got bored on the turnpike, and so i gassed it, and was crusin along then whaaaaa... it shut down, and didnt have a responce till it hit 90mph again. i was mad, because i had no idea that it had one. ive accidentally shut it off like 2 other times, just going down the turnpike not paying attention, and i would hit 95.. and you get the idea.
 

·
Registered
Joined
·
1,832 Posts
Yeah... I have never hit my speed limiter, oh wait, I don't have one!!!!!!! (superchip) anyway, I was just thinking... for those w/ the limiter, if you unplug the entire gauge cluster, does it still do it, or is it gone then? what my point is, I wonder if the cable that they say to unplug that disables the speedo too, goes through the computer first, or if it goes to the cluster, then when the cluster hits 95, sends a signal to the computer. If it goes to the cluster to get the speed, I would think that you could run the cable to the cluster that sends the speed, but unhook the cable that sends it to the computer. Personally, I doubt that this would work since the computer obviously sends the speed to the cluster, but someone did say if you unhook the gauges, it disables it. Anyway, I'm thinking if unhooking the gauges works, you could plug one wire harness in at a time to find out which one turns on the limiter, and then maybe narrow it down to the specific wire. And if that isn't possible, you could probably add an extra speedo, and ditch the stock one.

DogP
 

·
Registered
Joined
·
12 Posts
i looked at a 4.3 computer and a 2.2 computer and the plug in under the dash is all the same will the power programer by hypertech work on the 2.2s that are made for the 4.3s? becouse the computer is all the same
 
G

·
Ok i have a 95 2.2 truck and my speedlimter is hit at around 92 mph. On my moms 95 cpi blazer the speedlimeter is 100 and it hits that easy.
 

·
Registered
Joined
·
98 Posts
if you unplug the guage cluster that just defeats the point...the computer still knows how fast you are going...the transmission thing works...i've done it to mine...it only takes five min.
 
1 - 18 of 18 Posts
Top