S-10 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
What spark plugs and wires do you guys recommend? Could knocking of the engine while you accelerate be a problem of bad spark plugs? thanks
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
most definitely could be.....or plug wires, I replaced my wires and it went away

taylor 8 mm wires are pretty good, just upgrade to 8 mm wires and the constant changing of wires problem seems to go away

Caleb
 

·
Registered
Joined
·
31 Posts
I recommend A/C Delco platinum plugs and Taylor are real nice wires. As far as knocking try the plugs and wires first. ALso is your service engine soon light on. If so you need to see what code is in the computer.
 

·
I rape little boys
Joined
·
1,329 Posts
dude...i don't know about the newer ones...they might come with Plat. plugs....but put whatever the mfg. had in there...and DON"T USE BOSCH...they are ****!!!!....SERIUOSLY....I amd running stock plugs and wires. on my 96 and she runs smooth...soo...it depends on what you are looking for...but don't go iwth SH!T....b/c it will bite you in the A$$
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #6 ·
Thanks for the advice guys. Oh and yeah... one of my lights came on. I'm pretty sure it was the abs light though.... don't think it was the service engine one. Anyone know??
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
that might be some type of speed sensor....if it happens again go to auto zone and ask to use the GM code gathering machine (forget technical name!) and find out what codes it would be throwing...or take it to a dealer.....

I have bosch platinum +4's on mine and I don't think they're great, but it seems to run pretty good for what it is......if I switch I'll go to denso iridiums or AC delco Plat's

Caleb
 

·
Oooo. It's so tiny!
Joined
·
1,108 Posts
badassminitrk said:
dude...i don't know about the newer ones...they might come with Plat. plugs....but put whatever the mfg. had in there...and DON"T USE BOSCH...they are ****!!!!....SERIUOSLY....I amd running stock plugs and wires. on my 96 and she runs smooth...soo...it depends on what you are looking for...but don't go iwth SH!T....b/c it will bite you in the A$$
Amen brother. Made the mistake of trying a set of Botch plus 4s in mine. Lasted about 3000 miles before they started missing. AC platinums are my 1st choice these days.
 

·
2 Litre Terror
Joined
·
1,964 Posts
DnL said:
What spark plugs and wires do you guys recommend? Could knocking of the engine while you accelerate be a problem of bad spark plugs? thanks
Stay with the stock plugs..As far as wires go...Aftermarket or factory. Aftermarket..Moroso,accel. As far as the knocking goes, it's highly unlikely that your wires would cause a knocking. even a bad plug would only cause a misfire..Not a knock...If its a knocking sound, check engine oil level. Dont have your sig in front of me but if the engine has some miles on it could be rod or crank bearing. A rattlyng is a sign of detonation. The air and fuel is lighting off before the spark plug fires shocking the piston and rod assembly. This can be caused by bad gas, timing out of spec (to far advanced) carbon build up (causes hot spots that light off the A/F mixture) Knock sensor is bad if that pertains.....Hope this info helps..Not flaming any other suggestions here.. Just some info..
 

·
Oooo. It's so tiny!
Joined
·
1,108 Posts
Re: Re: spark plug help

02REDXBLAZE said:
Stay with the stock plugs..As far as wires go...Aftermarket or factory. Aftermarket..Moroso,accel. As far as the knocking goes, it's highly unlikely that your wires would cause a knocking. even a bad plug would only cause a misfire..Not a knock...If its a knocking sound, check engine oil level. Dont have your sig in front of me but if the engine has some miles on it could be rod or crank bearing. A rattlyng is a sign of detonation. The air and fuel is lighting off before the spark plug fires shocking the piston and rod assembly. This can be caused by bad gas, timing out of spec (to far advanced) carbon build up (causes hot spots that light off the A/F mixture) Knock sensor is bad if that pertains.....Hope this info helps..Not flaming any other suggestions here.. Just some info..
Good call, we got carried away on the plugs. :) Maybe he should try a tank of premium to see if that makes it quit. That might eliminate a few causes.
 

·
2 Litre Terror
Joined
·
1,964 Posts
KISS..Keep It Simple Stupid..No offense made to you guys..Try the easy stuff first....:thumbup:
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
My truck made knocking noises and stuttering and **** and it was the plug wires, thats why I said plug wires right off cause it happened to me, but it wasn't the only things that could've been wrong, just one thing that happened to me and that is a big problem with these engines......

Caleb
 

·
Med School member
Joined
·
179 Posts
Ok guys check this out

I have a 2000 Sonoma 2.2, when I accelerate between 100 and 3500 rpms the engine stutters.......like a vroooooommmm puh rooooom.........it's just for a split second, but keeps getting more and more frequent, is this spark plugs, and wires??
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
sounds like what mine did when my wires went bad....but like we've said before, that could be only one thing

Caleb
 

·
Registered
Joined
·
63 Posts
I'd deffinently check your wires? Do you have a shrienk sheild or a plastic cover over them? Cause sometimes they might rub or lay against a metle peice or something hot, and that could melt them. Good luck
 

·
I rape little boys
Joined
·
1,329 Posts
hehe...i dont'know what your problem is pal...lol...my truck will backefire...trhough the intake every once in awhile....i don't care anymore...lol......stupid ****.....but it does not do it that often...and that backfire....could be....you TPS doin that..i have seen it...a millino times
 
1 - 20 of 21 Posts
Top