S-10 Forum banner

1 - 15 of 15 Posts

·
Anybody got 20's?
Joined
·
5,731 Posts
Discussion Starter #1
i looked at the edelbrock tes headers and they say for 98 cpi. i'm just wondering if they will bolt on to a 02 sfi engine. do the cpi's have one 02 sensor or two or will the flange bolt on the same as a cpi compared to a sfi engine. i am looking at headers and exhaust for my next upgrade. just like the edelbrocks because they come with the y-pipe. i know i could get jba with a slp y-pipe.
 

·
Black SS
Joined
·
5,869 Posts
The 98 engines aren't CPI so if Edelbrock doenst know what there posting on there website, your betting off calling them to see if they will work for your truck. That way if they dont fit you can send them back because they dont know sh*t about their product. I have the JBA Slp combo, I like it alot.
 

·
Project: Sabriel
Joined
·
12,507 Posts
there's no such thing as 1998 CPI....CFSI, i believe, but not CPI. id get the year-specific, and JBA;s.
 

·
Registered
Joined
·
1,329 Posts
Aftermarket 95% of the time list CPI for the newer 96+ even though technically there not, cause its still considered central port. But even with that the newer 2001+'s use air injection which will be a problem since 2000's and down didnt readily use air injection!!
 

·
Gaaoooooo
Joined
·
13,572 Posts
My 2000 has air injection and so does my brothers 2000, he got jba's for really cheap without air injection provisions, think that will be a problem?
 

·
Gaaoooooo
Joined
·
13,572 Posts
964pt3 said:
I've heard as long as the air injection is kept setup and flowing just anywhere the comp is fine with it.
That is what I figured, a friend of mine removed the injection setup on his 91 caprice and nothing changed, but I figured maybe obdII would be a little more picky. The air injection on my truck has an electric pump, correct?
 

·
Registered
Joined
·
1,329 Posts
Yeah its electric and under the pass side of the radiator. As long as its connected and the comp see also will know it is, it wont code!
 

·
Registered
Joined
·
466 Posts
I've got the tes headers on my 2001. No air injection at all and I get a code about every 2 weeks i have to clear. The y-pipe wont bolt up either, I had to have it welded to the rest of my exhaust. Had to get rid of the a/i for the powerdyne.
 

·
The Dave Inc.
Joined
·
11,720 Posts
dont whore....this idiot just decided to dig up an ancient thread for some reason
 

·
Got Beer?
Joined
·
1,599 Posts
xxosiris9xx said:
dont whore....this idiot just decided to dig up an ancient thread for some reason
The reason is because he was doing me a damn favor. And what you posted wasn't whoring either right? It didn't help me any...
 
1 - 15 of 15 Posts
Top