S-10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Last night I was driving down the road and my whole dash shut down. The tach, the head unit, pretty much all the dash lights. When I got out of the car, I realized that none of my running lights were on and my tailights were out. The breaklights work, and the headlights are kind of working, loks like some sort of emergency light? I read the manual, says something about an internal circuit or something... Please help!!!
 

·
Early Member
Joined
·
3,166 Posts
Check your illumination fuse in the fuse box. I will check some more info.
 

·
Registered
Joined
·
16 Posts
It may be a bad ground...

Check your grounds - I know on my 96 sunfire there's a ground wire that is bolted to the battery tray.

Remove the bolt and the whole dash/buzzers, etc go out. I don't know about how it affected the external lights (didn't drive it at night) but I do know it did kill the DRLs since they're driven by the cluster.

Good luck.
 

·
Registered
Joined
·
222 Posts
my trucks been at the shop for a month now, everyone just scratches their head when they look at it . it sounds like the same problem, i was making a right turn really hard trying to slide a little when al of a sudden at the same time the stereo makes a staticy sound and shuts off, thegauges on the dash all go to zero, all the trouble lights come on then shut off. I get to where im going and notice that i dont have any headlights just parking lights. so like a idiot i shut the truck off then i think maybe i should see if it will start again so i crankit and it turns over quite a few times thenstarts so i shut it backof and start checking fuses
the problem was under the hood in the power relay fuse box a 50 amp maxi fuse labeled INT BAT was blown, when i went to put a new one in it shot sparks as soon as the fuse touched the terminals so i think there is a power wire shorted SOMEWHERE?
without the fuse in there iturned the key and nothing. The worst part is that THE ONLY thing on the truck that works right now is the "service engine soon" light. You might want tocheck that fuse im talkin about. Does your truckstill start, or have you got it fixed yet? let me know because i think were in the same boat here. infact this is my first post,your post made me go and register. PLEASE HELP GUYS thanx p.j.
 

·
Pressurized 2.2 Member
Joined
·
3,233 Posts
most likely a relay. test all of those and then make sure everything you ahve ever hooked to that truck has proper covering over the grounds and the positive wires.
 

·
Banned
Joined
·
21,222 Posts
when changing/checking fuses, always disconnect battery!

When working with any hot electrical parts that you dont need the battery hooked up, disconnect it!

:(

When you took that hard turn, did any of the amps in your stereo system have any wires come loose?
 
1 - 7 of 7 Posts
Top