S-10 Forum banner

1 - 5 of 5 Posts

·
4 Year Intermediate Tech
Joined
·
1,829 Posts
Discussion Starter #1
I drive about 26.4 miles to work and after parking a few minutes I smell slight gas fumes. Is this normal for a carb with a open element? Has a electric fuel pump with returnless system. Pressure in the fuel lines reaches as high as 10 psi with underhood temps and engine off but usually goes to 0 after the engine cools and sits a few hours. No startup problems or fuel leaks.
 

·
4 Year Intermediate Tech
Joined
·
1,829 Posts
Discussion Starter #2
Alright I think I figured it out. Fuel tank vent hoses, and charcoal can are venting under the hood. Really need to get rid of that thing and vent the tank to the air cleaner with a custom barb fitting. Also need to run the float vent somewhere
 

·
4 Year Intermediate Tech
Joined
·
1,829 Posts
Discussion Starter #3
Man this thing smells like a giant gas spill haha
 

·
Registered
Joined
·
459 Posts
Sounds like you need a new canister. Don't know if these are the type, but some were designed so you just replaced the element inside.
 

·
4 Year Intermediate Tech
Joined
·
1,829 Posts
Discussion Starter #5
Canister isn't connected to anything lol, the hoses I moved to the inner fender area.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
2 Participants
greasemonkeys10
S-10 Forum
S10forum is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!
Full Forum Listing
Top