S-10 Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
796 Posts
Discussion Starter · #2 ·
1cln_sdime said:
Every time i hit sides my rear side that is down wants to lift up and level out with the sdie that is up. Anyone else have this problem. my valves are blitzluft, avs 9 switch. Those are the only 2 things i could think are maybe doing it. If anyone has a idea what it might be let me know.
 

·
it's a french bulldog
Joined
·
413 Posts
quick guess, maybe your wires for the "ups" in the rear are crossed. making you be able to lower a side fine, then when you go to switch to the other side it's raising it back up. i'm not familiar with that switchbox, but i assume it has individual controls? try running through all the switches.
 

·
Point Blank Customs
Joined
·
49 Posts
1. you might have some debris stuck in your inflate valve on that corner causing it to improperly seal.

2. you have a valve mounted backwards. You will see an arrow on the valve to designate which way the air should flow through it.

Rick
 

·
Frame Laying Member
Joined
·
2,068 Posts
SlammedDime said:
What sort of rear suspension are you running?
x2
 

·
Still 2 High
Joined
·
7,539 Posts
dutn01sdime said:
thats ur problem its a three link dude....go four link i lay hella sides freaks ppl out
I dunno about that, I just finished installing a 3-link yesturday, and this truck gets mad sides.
Look for the thread tonight in Members Rides, JollyGreenMini and Whoeba's truck.
 

·
Registered
Joined
·
3,789 Posts
i have the sd 5 link i have the same problem with mine but the opposite bag isnt filling it just lifts and crushes the bag in from the suction i can hit sides but they are kinda weak and u cant just fill the back my 1 bag filled lifts the whole rear of the truck at about 90 psi i have the urethane bushings or whatever they are in the 5 link i think thats my problem sounds just like what my truck does but i get mad lift
 

·
Registered
Joined
·
13,733 Posts
Well a slam bag still exurtes a lot of force even with no air in them... so when trying to simply inflate one side (if this is an over the axle setup), the otherside will want to come up, since it is pushing up already. Similar to the issue that i've seen from some slam bag owners in which the rear will not fully compress and lay frame because the force from the slam bags, even with no air, was still holding them up.
 

·
Registered
Joined
·
13,733 Posts
dutn01sdime said:
thats ur problem its a three link dude....go four link i lay hella sides freaks ppl out
Incorrect my friend.. I should get pics of my 3 link layin 'hella sides'... maybe when I get home from school tonight, or tomorrow before work...
 

·
Registered
Joined
·
13,733 Posts
SlammedDime said:
Incorrect my friend.. I should get pics of my 3 link layin 'hella sides'... maybe when I get home from school tonight, or tomorrow before work...
A lil delayed on the pics... but here they are (I used to have a 4 link... now its a 3 link)







 
1 - 20 of 20 Posts
Top