S-10 Forum banner
1 - 2 of 2 Posts

·
SFBD 4 door
Joined
·
7,871 Posts
Discussion Starter · #1 ·
well when ever i turn on my headlights my gas gauge needle goes down, my temp needle goes up and my volts go to 9. my service engine soon comes on as well as my check gauges. I dont know what the hell is wrong and im racking my mind to figure it out. but i know when i started it up earlier the the dash lights were out and when i had my headlights on the bright light indicator was on and my turn signals were on but no dash lights but when i opened my door they turned on. then i got a 14 volt charge and everything was fine till i messed with my radio and the volts went down can anyone help me in tennesse or can someone on here point me in the right direction!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :rant: :rant: :rant: :rant: :rant:
 

·
SFBD 4 door
Joined
·
7,871 Posts
Discussion Starter · #2 ·
TrYiN2LaYaDiMe said:
well when ever i turn on my headlights my gas gauge needle goes down, my temp needle goes up and my volts go to 9. my service engine soon comes on as well as my check gauges. I dont know what the hell is wrong and im racking my mind to figure it out. but i know when i started it up earlier the the dash lights were out and when i had my headlights on the bright light indicator was on and my turn signals were on but no dash lights but when i opened my door they turned on. then i got a 14 volt charge and everything was fine till i messed with my radio and the volts went down can anyone help me in tennesse or can someone on here point me in the right direction!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :rant: :rant: :rant: :rant: :rant:

well thanks for everyones help i think i found it. or i hope i fixed the problem if it still keeps messing up im gonna pull the dash this weekend and paint it while its out lol. what a way to do shit huh
 
1 - 2 of 2 Posts
Top