S-10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
95 S10 2.2L ext cab, 110,000 miles. SES light will usually come on and stay on when I'm on the highway and doing 60MPH+. Goes off when I shut the engine off and will stay off until I hit the highway again. Never comes on when doing city driving (30-40MPH).

This may be related: Got the state inspection done yesterday and failed because the NOX (sp??) levels are high. Guy said maybe catalytic converter or EGR are bad?

Are these two issues related? How do I figure out without just replacing parts blindly? I see you can check the computer yourself with a paperclip. Anyone have details on how to do that for a 95?

Appreciate all input.
Brett:guitar:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
Forgot to mention some of the mods:
replaced plugs, spark cables a few months ago
replaced alternator
replaced injectors about a year ago
new rear exhaust put on about a year ago
 

·
Registered
Joined
·
6,374 Posts
Autozone will run diags on the Computer for you
and it is possible that this could be caused by the cat being clogged
can get one that is made for direct replacement and its just like 3 bolts on each side to drop out and then back in or you can get it welded in
 

·
Chrome is Gay
Joined
·
3,693 Posts
HuTcH said:
Autozone will run diags on the Computer for you
and it is possible that this could be caused by the cat being clogged
can get one that is made for direct replacement and its just like 3 bolts on each side to drop out and then back in or you can get it welded in
:werd: I was thinkin the same thing, just take it and have it tested
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Called my local AZ and they said they do it but the SES light must be on at the time they scan!? I figured it would read the code from memory.

In the mean time, sounds like jumpering ports 5 and 6 with a paperclip will give me the codes. My truck has the ODB II connector (16 ports) but the emissions sticker doesn't show that it's ODB II so sounds like it's got ODB I computer with ODB II connector. Anyone agree?

It's a 95, bought around Thanksgiving in 94.
 

·
Registered
Joined
·
6,374 Posts
damn ummmm 95 damn 94 and 95 they used both ECU's that sux..and used all obd 2 parts regaurdless is it a CPI engine or a TBI engine? if its TBI its mroe likely to be a OBD1 the CPI i think was OBD2

and they should be able to read the codes even with the light off
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
OK, did the paperclip trick and shows code 32, which is EGR Vacuum Control. Something I can resolve myself or need to have it done? I'm not too mechanically inclined so if it involves digging deep into the engine or start pulling off stuff that would probably count me out. I'll search the forum for similar stories but thought I would post this update and see who has input.
 
1 - 7 of 7 Posts
Top