S-10 Forum banner

1 - 4 of 4 Posts

·
i like caffeine
Joined
·
207 Posts
Discussion Starter #1 (Edited)
service light came on, took truck to autozone, got code p1153. went to the chev dealership and was told it would be 75 to diagnose, i told the guy ill think about it. went to gm dealership across town, got to look at the computer while the service guy told me what the code was- o2 sensor--bank2 sensor1. its 75 labor, and ~120 for the o2 sensor

how many of you have gotten this code?
did it just end up being the o2 sensor?
how much did it cost you?
which o2 sensor is this?--before/after cat, which y pipe...?

thanks for your help, hopefully my experience can help others

kevin
 

·
Clean N' Dark
Joined
·
1,921 Posts
Don't go to the dealer to get it done, they will RAPE you.
 

·
Quicker than a Hummer!
Joined
·
349 Posts
depending on the dealer... if the dealer is a family friend of 20 years then its different ;)
 

·
i like caffeine
Joined
·
207 Posts
Discussion Starter #4
well... problem resolved. taking a trip of 300 miles tomorrow, so i went to the dealer and bit the bullet. ended up costing me a little over 200 everything installed. oh well, lets me know that there were no other problems that i will have to deal with on my journey. i feel its money well spent now, for the security later on.

problem ended up being a faulty o2 sensor, as i had indicated earlier, so for the do it yerself'ers head down to autozone, get your codes pulled, and pick up the o2 sensor.
best of luck to everyone else.

kevin
 
1 - 4 of 4 Posts
Top