S-10 Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
208 Posts
Discussion Starter · #1 ·
So on my way to work today my service engine light came on out of no were. I have asked a few difernt ppl if they have any ideas what could have caused this and got a bunch of dif answers a couple they have told me was that my oil needed to be changed badly and this was true, i got it changed right after work today and the light was still on. THe other was that its in need of the 90k tune and its just letting me know, but the only thing with that is i just gave it a tune up and it just hit 94k haha the light is a little late if thats what it is. Is there any way i can check with out haveing to get it diagnosed(Sp?) with out going to the shop? I like to do all the work my self and being the cheap bastard i am i FIgured some of the s10 gurus on the board could help me out. Any info or adivce is appricated thanks
r0cky
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #3 ·
devilman13xx said:
go to any parts store and they will scan it for free
ya but i live in the middel of nowere haha and every were closes at 6 around here and thats what time i get off bleh ill have to take a half day or some thing tomorrow
 

·
AVTekk is my HERO
Joined
·
1,232 Posts
Make sure gas cap is on tight
 

·
The Noma is gone
Joined
·
528 Posts
could be a spark plug is about to blow... :haha: that happend to me.. 2 days after i bought my noma,the light came on i was like "wtf" so i was gonna take it to my mechnic on monday, of course it happens on a weekend. didn't make it to monday. but it was an easy fix thank god
 

·
YOU ARE GAY
Joined
·
1,781 Posts
ive had this same problem for about 2 years now and ive did everything to get it to shut off. the dealership ran the diagnostics on it and cleared it off but when i left the dealer it turned back on. there was a recall on the s-10 and sanoma to get the malfunction indicator lamp replaced this is probaly what is causin it to turn on. they should fix it for free if thats the problem
 

·
Registered
Joined
·
568 Posts
"you can go to any parts store and have the codes read"

true, but it may not be as simple as with the obd2 comps. the obd2 predict problem with the emision system. so you may have 1 bad o2 and the code reads simply random misfire. you really need to find someone with a diagnostic programe and a laptop or pda. at 90-124bux an o2 (s-10 have 3) you can spend some dough if you just start replaseing sensors.

you said your oil was way overdue? does it have anyouther symptoms?
 

·
AVTekk is my HERO
Joined
·
1,232 Posts
those OBD2 codes have a reference to a few things say (randomly naming something now) you get code 1352 it would refer to the fuel and narrow it down to a canister or fuel cap was left open. often times places like auto zone have a book that can give them the list of things for that code and it narrows the problem down... A LOT
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #12 ·
bvr775 said:
"you can go to any parts store and have the codes read"

true, but it may not be as simple as with the obd2 comps. the obd2 predict problem with the emision system. so you may have 1 bad o2 and the code reads simply random misfire. you really need to find someone with a diagnostic programe and a laptop or pda. at 90-124bux an o2 (s-10 have 3) you can spend some dough if you just start replaseing sensors.

you said your oil was way overdue? does it have anyouther symptoms?
nope that the only thing that i could think that it would be other than that it runs like a champ.
My friends buddy has a diagnostic tools so he said he will come by this weekend, hopefully we can figure it out!
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #14 ·
k i got the read out from my local autozone it came up as P0420 catayest efficiancey below threshould they told me my cat was clogged and i should just get a new one what do u guys think?

and again thanks for all the help guys!
 

·
Registered
Joined
·
568 Posts
that is also a sign the post cat sensor is bad. if your engine ain't bogging down like it have a fuel problem then more than likely the cat is fine.
but just in case.....pull one of the pre cat o2s and see if the idle comes up. if it dosn't your cat is flowing fine, but that dosn't mean it's good bang on the cat with a soft rubber mallet or your fist if it ratles real bad your honycomb crap is loos and moveing around.
Your emisions are covered for a exstended life after your warrenty (i thinck it's like 80,000miles or 7 years, but I'll check too make sure)
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #16 ·
bvr775 said:
that is also a sign the post cat sensor is bad. if your engine ain't bogging down like it have a fuel problem then more than likely the cat is fine.
but just in case.....pull one of the pre cat o2s and see if the idle comes up. if it dosn't your cat is flowing fine, but that dosn't mean it's good bang on the cat with a soft rubber mallet or your fist if it ratles real bad your honycomb crap is loos and moveing around.
Your emisions are covered for a exstended life after your warrenty (i thinck it's like 80,000miles or 7 years, but I'll check too make sure)
It bogs down pretty bad now that i think about it when i first start her up. I just figured cause it was cold cause it dont do it when i come to a stop at a light.
 

·
Registered
Joined
·
568 Posts
if your uncomfortable testing it yourself.. take it too a good exhaust shop thats been around awhile and let them have a look at it.
 

·
Registered
Joined
·
26 Posts
Only 2 good ways to test a CAT. One is to go to a muffler shop and have them check it for you, although they will tell you it went bad even if it didnt. Two is to get a scan tool and see what the HO2S are doing. The O2 sensors before the CAT should be toggeling from rich to lean constantly and the O2 sensor after the cat should be steady. If it is toggeling like the pre CAT then your cat is bad.
 

·
Registered
Joined
·
568 Posts
you take it to a shop their going to test it the same way I told you too exsept they stick a gauge in the pre 02 hole instead of listening to the idle because the epa says they have too now.
 

·
Registered
Joined
·
208 Posts
Discussion Starter · #20 ·
well i went and bought a new cat and pulled my old one. I lookedand side and the screen was smashed in and had some piece of rubber or something in there jamed into thebottom of it. I should have it all finished up tomorrow night. Ill let u guys know what happens
thanks again for the help
 
1 - 20 of 20 Posts
Top