S-10 Forum banner

1 - 5 of 5 Posts

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter #1
Hey,
I've got some serious probs right now with the ole' S. For starters, I hauled it over to a shop yesterday since it blew another v. cover gasket and to also replace the intake gaskets. They later told me that I had a serious blockage in the TBI to the PCV valve so it wasn't getting any vacuum.(leaking prob solved). Then they told me that I had a bent push rod and totally screwed lifter. Got them replaced...TODAY came a whole new scenerio. After they got it all back together, they found that it wouldn't start on its' own, and had to use starter spray for it to catch. Once running, the idle was a little funny. HERE'S the KICKER!!! My shifter(auto) has a little play before going into reverse, so when they slid it down, the engine started running real rough..I witnessed this also. The only thing one could come up with is that there could be a ground problem SOMEWHERE. It wasn't doing this before I took it in nor had problems starting it. I took my factory coil over there in case the ACCEL one was giving up also. IF ANYONE has a clue about my delima and theirs, please shed some light on it. I told them I'd call and let them know if I came up with any clues.

Thanx
Mike
"down but still DEDICATED"
 

·
Registered
Joined
·
12,726 Posts
Your intake gaskets were replaced? If so possably the distributer could be off by a notch from when they restabed it in. Other than that I would suggest checkin the ground straps and wireing to distributer and tb.
 

·
ESSTEN Concepts Founder
Joined
·
465 Posts
Discussion Starter #4
ya know I actually thought about that too, other than the distr. grounding deal. On my model (2.8) you dont have to take the dist. off to get the intake loose. He told me that they hadn't messed with it yet. Something a friend told me 2nite reminded me of when i did some head work a while back. When adjusting the rockers, it was difficult to get it to start right off without playing with the adjustments. I need to call them as soon as they're open and ask if they adjusted them. HELL... the covers etc. are already installed LOL. I do remember that there's a ground on the backside of the head also, but don't see why they'd mess with it. It just sounded weird that all of their mechanics were totally baffled over the ordeal. I asked if they called chevrolet, and they didnt. I just figured someone over there would have a better feel about the whole thing.
ALSO.. HAHA a friend mentioned that it may just be pissed off at me since I'm not the one working on it LOL... we kinda got a bond goin on hehe

Mike
Down N DEDICATED
 
1 - 5 of 5 Posts
Top